multiple zend extensions

Discussion in 'Server Operation' started by Tomislav Aurednik, Sep 6, 2018.

  1. Hi,
    Shared hosting, ispconfig 3.1.9. Client uploaded a page, which requires zend extension "ioncube_loader".

    Custom PHP ini settings

    zend_extension =/usr/lib/php/20151012/
    safe_mode = off
    output_buffering = on
    register_argc_argv = 1
    max_execution_time = 2000
    ... and so on​

    but the problem is as follows : ispcconfig always adds one line above​

    Because ioncube_loader is not in a first line of php.ini web site doesn't work. Until I manually remove the first line. But next click in ispconfig adds this line back.

    How do I disable this for this client only ?
  2. florian030

    florian030 Well-Known Member HowtoForge Supporter

    Are you, that ispconfig adds opcache?
    BTW: we enabled ioncube for php-versions global so a client does not need to add zend_extension to any settings.
  3. 100% sure. When I manually edit php.ini and comment out the line "" everything works fine. Until I enter ispconfig setting for this site. Don't even have to confirm anything, in few seconds php.ini is changed with mentioned extension on a first place...

    But in the meantime it seems to me that a client changed something. Now anything I do, site always works...
  4. florian030

    florian030 Well-Known Member HowtoForge Supporter

    Maybe you have some custom-configs. ISPConfig does not add any zend_extensions to ini-files. You can check this yourself:
    cd /usr/local/ispconfig
    grep -Ri zend_extension

Share This Page