multiserver set-up - install ispconfig instance on slave - mysql problem

Discussion in 'Installation/Configuration' started by 5t3f4n, Dec 12, 2016.

  1. 5t3f4n

    5t3f4n New Member


    have got a multi-server set-up with a web, db, and mail server.

    have added now an owncloud server.

    all servers are running perfectly fine.

    now i want to manage the newly added own-cloud server via ispconfig 3.1 as well.

    i've inserted the owncloud server records in the ispconfig master database, and can see the owncloud server in the ispconfig>monitor>server state page ... but with no details like ispconfig version and OS ((Debian Wheezy/Sid) ISPConfig 3.1.1p1) and mail, virus, status etc is missing also ...

    as next step tried to install ispconfig on the slave (owncloud server) - the install breaks after selection of:

    MySQL master server database name [dbispconfig]:

    many warnings are thrown - the last one is:
    PHP Warning: mysqli_connect(): (HY000/2002): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 204

    error message at the end:
    ERROR: Unable to create MySQL database: dbispconfig.

    mysql has stopped and will not start again on the owncloud slave

    # /etc/init.d/mysql status
    [info] MySQL is stopped..

    # /etc/init.d/mysql start
    [....] Starting MySQL database server: mysqldNo directory, logging in with HOME=/
    [FAIL. . . . . . . . . . . . . . . . . . . . . . . . . . . . failed!

    i've checked hosts files, mysql/my.conf, uninstalled mysql-client and mysql-server, rebooted (note: a reboot of all servers does help, mysql on owncloud slave server runs, but stops again at the same stage after trying to install ispconfig), etc ... don't know what i need to check to get ispconfig instance running on the owncloud server, resp what I need to check on mysql to get the install finished ...

    any ideas what i need to do?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem seems to be a mysql configuration issue, that you can't install ispconfig is just a following error caused by the unavailability of mysql. Check the syslog file for mysql errors after you tried to restart mysql.

Share This Page