MyDNS + MyDNSConfig software appliance

Discussion in 'General' started by michaelkjohnson, May 17, 2006.

  1. michaelkjohnson

    michaelkjohnson New Member

    The main page for the system is a "landing page" that links to two URLs: the rPath Appliance Platform web management console, and the MyDNSConfig interface. Assuming that your system is called "", point your browser at "" and you'll see both links.
  2. SyberWizard

    SyberWizard New Member

    Thanks, that did it.:) It appears that port 80 does not work at all until after completing the rAA setup. It never occurred to me to go back and check it after setup!

    So, from the observations of a novice. There should be some guidance that:

    need to turn off the firewall, as there is no selection for allowing DNS communications, OR add DNS ports to the firewall (better solution).

    need to install the Everything selection in order to get MyDNS loaded. Can Everything be set as the default selection?

    It would be great if that last screen mentioned that, in order to access the rAA setup, one must use port 8003/8004, and after completing setup, go back to the standard port 80.

    My final question, and I do not know if this is an issue with LochDNS or MyDNS, but DNS Report complains that this server does not respond on TCP, only UDP. How do I correct this?
  3. falko

    falko Super Moderator ISPConfig Developer

    Open /etc/mydns.conf and set
    allow-tcp = yes
    Then restart MyDNS.
  4. michaelkjohnson

    michaelkjohnson New Member

    I've never seen it not work at install time, but I do tend to use the virtual images rather than the anaconda image for testing point updates, and it's quite possible that I've just not noticed. I wonder if this had to do with the firewall, though?

    I can tweak the firewall configuration for future releases.

    I should simply disable the package selection screen so that all necessary software is always installed.

    rAA should be modified to link to the MyDNSConfig console. You shouldn't need to go to rAA first; the landing page should be accessible as soon as you install, and it should point both to rAA and to MyDNSConfig.

    Thanks for your detailed and useful response, and glad to hear that the system is working for you now (assuming falko's advice about allow-tcp = yes has resolved the other issue you encountered).
  5. SyberWizard

    SyberWizard New Member

    Yes, it is now responding to TCP DNS requests, so that is working. Today I am working on the second DNS server, so I get to play with that functionality. I love it when progress is being made!:)
  6. michaelkjohnson

    michaelkjohnson New Member

    Update: Month of PHP bugs

    Just a note for anyone worried about the security of their lochDNS systems due to security issues exposed during the "month of PHP bugs" -- as of last night, all updated lochDNS systems will include a new version of PHP that has been patched for the relevant security issues.
  7. z00te

    z00te New Member



    i'm new to mydns, so looking the faq i found this answer to my problem:
    How do I use MyDNS but still allow external (recursive) lookups, like for ""?
    To do this you need to use a program that does recursive DNS lookups. I recommend dnscache.

    the only solution is to install dnsccahe on the appliance?
    other way to resolve non-local domain names?

  8. till

    till Super Moderator Staff Member ISPConfig Developer

  9. z00te

    z00te New Member

    Tnx for the link and the hint,

    i have installed as the tutorial (well, adapting to rpath linux and using conary to install dnsmasq 2.38), and all seems to work from the virtual machine.
    But from the others pc on the lan it seems that the caching function doesn't work; using dig to test the query time it seem too high.
    No problem at all with the forward. Any idea on why the cache only works from the localhost... i've tried lot of config but no luck...

  10. michaelkjohnson

    michaelkjohnson New Member

    finding and configuring dnsmasq

    I want to be clear for other readers of this thread that dnsmasq is available for installation in lochDNS by running the command "conary update dnsmasq".

    dnsmasq has a lot of configuration options, as you've discovered. I assume that you have tried increasing the cache size. The dnsmasq that I assume you have installed (from [email protected]:1) is set up primarily to integrate with dhcpcd as a local redirecting cache for laptop systems that are booted in different contexts at different times, and might have some subdomains that should be sought sometimes via ethernet and sometimes via VPN. In particular, the /etc/dnsmasq.conf file it includes contains the line "resolv-file=/etc/resolv.conf.static" which you probably want to comment out if you haven't already.
  11. voipfc

    voipfc New Member

    How much RAM can lochDNS get by with?
    I expect to use it only on at most 100 domains.
    Given that for the most part it will be doing lookups on a small database shouldn't 48 or 64Mb be enough?

    I can probably run the web interface elsewhere to minimize the memory requirements for that aspect.
    Last edited: May 14, 2007
  12. voipfc

    voipfc New Member

    How to add domain name as resource record in Mydnsconfig

    I am using mydnsconfig and I noticed that after adding the root domain itself ie. by leaving the Name edit box blank it can't be edited any more, as there is nothing to click on.

    Is there a way to enter something in the B]Name[/B] edit box that will allow it to be edited?

    A work around though will be to delete it and add it again with the new details, but that is not ideal.
  13. michaelkjohnson

    michaelkjohnson New Member

    investigating memory sizing

    The memory requirements are unlikely to scale significantly with domains. The web console (what we used to call rPath Appliance Agent, but now call rPath Appliance Platform Agent) currently consumes about 30MB of memory, though much of that does not get used actively. (We at rPat are working on a project to reduce that; much of its memory use comes from using turbogears, which itself imports code that the agent never needs to use.)

    The virtual images include a 128MB swap file. You can use the "free" command to determine how much memory is used, and watch the output of "dstat 10" (the "10" is arbitrary and tells how many seconds at a time to look at) and see if the system is swapping under normal use. You can generally ignore "so" (swap out) events, but if you are getting many "si" (swap in) events then you need more memory assigned to the image. I've been running my images with 128MB of RAM; that's probably more than they need.

    The web server doesn't really use that much memory. mysqld and the appliance agent are the main memory users. mysqld is unlikely to change in this respect (probably 18-20MB in light use) but the appliance agent will become lighter.

    I have not done anything to try to reduce memory usage by apache httpd. You can certainly follow tuning guides (ask google...) for your situation.

    I hope that helps.
  14. jordan

    jordan New Member

    It will be nice to have some easy installable images from MyDNSConfig.
  15. michaelkjohnson

    michaelkjohnson New Member

    LochDNS 0.12 is available for update

    Key updates:
    • Filesystem should no longer fill up with logfiles, because I have added cron to the images. My test rig involved lots of backing up and restoring and so didn't show this problem caused by cron not being included in the images. Sorry to everyone who was inconvenienced, and thanks to the user who reported the issue.
    • VMWare images will have the open-source open-vm-tools installed.
    • New version of the rAPA console with all current updates and fixes.
    • Many more debugging and information packages have been added (things like dmidecode, ethtool, libusb, net-snmp).
    • LochDNS instances can now mount iSCSI storage for easy extensibility.
    • All applicable security updates have been applied.

    As usual, make sure that you have enabled backups. They are small, cheap, and easy. Also, they work! Also as usual, do a backup before the update. The fact that I haven't seen errors in my test rig doesn't mean that there are no bugs...

    This is a large update involving a large part of the system. Expect it to take several minutes, even on systems with fast network connections.

    Reboot your LochDNS instance(s) after upgrading. To do that, go the Schedule Reboot option and choose Reboot Now in the web console, or shutdown -r now at the command line. The "restart" that is performed automatically after the update is the web console only, it is not a reboot.

    I am also pleased to announce that 64-bit images are now released for vmware, xen, and system installation. (mydns was clearly not written with 64-bit systems in mind, but I made it compile...) You can download 32-bit and 64-bit images from the LochDNS project in rBuilder Online

    If you have an existing image that has run out of disk space, the workaround is to log in as root at a text console, and run the following three commands:
    • /etc/cron.daily/logrotate
    • rm -f /var/log/raa/*.1
    • shutdown -r now
    The reboot is the easiest way to make sure that all services are running correctly that might be malfunctioning after running out of space.
    Last edited: Oct 22, 2007
  16. brifish

    brifish New Member

    Sorry, this is more of a support question for your rpath image. I wanted to sample the concept and give the LochDNS appliance a test run. I've loaded the image and I am able to get to the configuration login webpage. However, I don't know what the login credentials should be. root doesn't work and I don't remember setting any other pwd's on the install. I've checked what documentation that I could find and there is no reference to the default login credentials. I'm able to login via the console as root, but just can't get logged into the web client. Any help? thanks - Brian
  17. michaelkjohnson

    michaelkjohnson New Member

    Summary: admin/admin and admin/password

    No problem! Glad to help.

    If you go to the appliance (http://ip-or-dns-address.of.your.appliance/) you'll see that it lists the default passwords and recommends that you change them at first login.

    There are two separate logins: one for configuring the appliance software, and one for MyDNS itself.

    For configuring MyDNS itself, the default username and password are "admin" and "admin".

    For configuring the appliance, the defaults are "admin" and "password".

    Again, those two "admin" accounts are unrelated -- I didn't try to modify the appliance web console software to intermingle with MyDNS configuration, or modify MyDNS to require you to set up an appliance configuration, in order to make it easier to keep both sets of software up to date. For the same reason, I'm not intending to add that either. They are really separate concepts, anyway. By way of analogy, in a blog hosting appliance, you wouldn't want everyone who had a blogging account to also have an idempotent account in the system management console. :)

    Hope that helps!
  18. brifish

    brifish New Member

    Thank you, yes that did help. Actually, I would have found this by going to the main website - but, on the anaconda (text-based) install, I didn't click on the "All" choice for packages. I just clicked the box for the rpath appliance. It was confusing because the https:// site came up, but the normal http:// site was not responding.

    After reading through the blogs a bit more, I re-did the install with the "All" checked and now I can get to both sites and I can see the notes that you made on the appliance web homepage.

    Thank you.

  19. michaelkjohnson

    michaelkjohnson New Member

    Glad it's working now

    Ah! In graphical mode, package selection is disabled. In some future release, the installer technology will change to be very much faster and package selection will not be available in any part of the interface. No schedule for that yet.

    Glad it's working for you now!
  20. michaelkjohnson

    michaelkjohnson New Member

    Announcing lochDNS 2.0

    I haven't had a lot of time to work on lochDNS updates since I wrote that (if anyone wants to join the development team, tell me about yourself...) but I have recently completed a refresh of the underlying platform. Please welcome lochDNS 2.0 -- I intend to migrate lochDNS 0.12 users (I never did make a 1.0 release...) to lochDNS 2 in the near future.

    As always, I recommend doing a backup before major updates; backups are cheap, fast, small, and easy because they contain only the potentially unique data, not the programs. About 100K plus the compressed mysql database dump.

    This release has the much faster installation process (on bare hardware or in a fully-virtualized virtual machine) that does not allow package selection at all; any additional packages will have to be added after the installation and the system told to keep them according to the instructions at Appliance:LochDNS

    In the "eyecandy" department, this release has a splash screen while booting and shutting down (amazing!) and the web console for system administration (rPath Appliance Platform Agent) has a significantly improved user interface. (There are, unfortunately, a few javascript incompatibilities with firefox 3 that haven't yet been fixed; primarily, after submitting a change, you have to reload the page to get to the next step. Sorry for the inconvenience; this will be fixed in an upcoming release.)

    More interesting (to me, anyway): the underlying platform has been significantly improved. Not only have the versions of practically all the elements of the underlying platform been updated, but they have also been built with additional security measures in place. The images include more utilities and diagnostic tools that were not included in the earlier version, but because the individual elements of the platform are smaller, the overall size of the images has not changed much. The functionality per byte ratio has improved. :)

    So download the new version and test it, and report success or failure.

Share This Page