MyDNS + MyDNSConfig software appliance

Discussion in 'General' started by michaelkjohnson, May 17, 2006.

  1. michaelkjohnson

    michaelkjohnson New Member

    Updating to lochDNS 2.0

    So far, there have been several hundred downloads of lochDNS 2.0, and zero complaints, and I haven't seen problems in testing. To update your older lochDNS 0.12 system to lochDNS 2.0, there are three steps.
    1. Back up your system using the rAPA console. Make sure you have a copy of the backup archive before proceeding. I haven't seen a failure yet, but you might be the first!
    2. Log in on the console or via ssh as root (if you have enabled ssh by setting a root password for the system), and run the following commands:
      service mysqld stop
      conary migrate --interactive
      After running that command, you will need to answer Y so that the update will be done. The update will take a while because it is a complete update of the underlying operating system, not just a few components.
    3. After the update completes, please reboot the system.

    You should now have a working lochDNS 2.0 system.
  2. lukasware

    lukasware New Member

    downloads and install

    # x86 VMware (R) ESX Server Virtual Appliance: VMware (R) ESX Image
    # x86 VMware (R) ESX Server Virtual Appliance: VMware (R) ESX Image

    What's the difference between these two downloads listed on the
    download page? one is download ID 27997 and the other is 27998.

    also when installing the X86-64 iso under ESX, it fails with:
    This kernel requires an X86-64 CPU, but only detected an i686 CPU

    Of course, my ESX installs other 64bit guests...including the 64 bit version of ESX...
  3. michaelkjohnson

    michaelkjohnson New Member

    That's a bug -- no, make that two bugs...

    Thanks for the bug report. In the process of defining all 20 (!) image types, I managed to accidentally define the 64-bit ESX image to have 32-bit contents. My mistake. I'll generate new images shortly.

    I should be clear that I test only a small sample of the 20 images -- I build them all for user convenience, but if I waited to release until I had found time to test them all, I'd never get around to releasing updates. :p

    At first glance, this sounds to me like a mistake setting up the instance under ESX. I have reproduced this so far only by setting up a 32-bit emulated system and attempting to run the 64-bit image on it.

    That said, once I get past that particular problem while testing those images, I ran into another problem: the ISO images won't install. I didn't realize that I hadn't tested ISO images since changing the way I generated them. I'll fix that too while generating the new images.

    I'll post here when the images are ready, and thanks again for the bug report!

    Update: see below for LochDNS 2.0.1 images with these fixes, and thanks again!
    Last edited: Sep 20, 2008
  4. michaelkjohnson

    michaelkjohnson New Member

    Announcing LochDNS 2.0.1

    All the updates to lochDNS 2.0 have now been made available as a new image set: LochDNS 2.0.1. If you have already installed, all you need to do is update, you do not need to re-install.

    Changes include a newer kernel version, latest open-vm-tools in vmware images, the 64-bit ESX image has been re-added (in 2.0, I accidentally built two 32-bit ESX images instead of one 32-bit and one 64-bit image), and the ISO images will now install correctly.

    Further bug reports encouraged and appreciated!
  5. michaelkjohnson

    michaelkjohnson New Member

    Announcing LochDNS 2.0.2

    All the updates to lochDNS 2.0 have now been made available as a new image set: LochDNS 2.0.2. If you have already installed, all you need to do is update, you do not need to re-install.

    rPath Platform Agent is updated to 3.1.0, and includes a text-mode console for setting up networking (useful particularly if DHCP is not available). The text-mode console displays automatically on virtual console 1; normal shell login is still available on virtual consoles 2-6. All current and relevant rPath Linux security and bugfix updates have been applied.

    Also, the lochDNS documentation has been updated with information on setting up your lochDNS system. As always, there is not very much to it. It's pretty much download-and-go, and the system guides you through the few required steps at the start. It's now just a bit easier if you have installed without working DHCP, thanks to the text-mode network setup.
  6. PivCon

    PivCon New Member

    Feedback / Question

    I just wanted to drop a note and say that I have found the LochDNS appliance to be a nice product. It is small, easy to setup, and is a great contribution.

    I have one question about v2.0.2. Perhaps I am missing something, but it doesn't appear that scp works. The scp binary is on the system, but there is no ssh binary which the scp program looks for when using scp to copy to a remote system.

    This works: scp file.exe dest.exer

    This does not: scp file.exe user@hostname:/tmp (prints error saying it can't find ssh.

    Finally, a request for a feature in future additions would be to have a configuration screen to simply MySQL replication of the MyDNS database so that when somebody wants to run two of these, replicated, it is easier to do then manually doing it. Even if it just made the process a little less cumbersome by having the slave user already in the mysql database, having a way to quickly edit the my.cfg file for master or slave mode, and having a web interface to get the mysql dump from the master and import to the slave for the initial replication setup.

    This would be a great addition. I did it manually on two LochDNS VM's and it works great.
  7. michaelkjohnson

    michaelkjohnson New Member

    one ssh, coming right up!

    Thanks! Glad to hear it!

    That's because I never added the openssh-client runtime, because I didn't think it would be useful -- I thought people would ssh/scp into it, but not out of it.

    It's a small addition, and the next build of LochDNS will have ssh in it as well.

    I've never set this up, and I cheerfully admit to having no idea how to do it. (Update: OK, I found now. The next release of lochDNS will include /etc/my.cnf in backups so that replication information there is preserved.) Also, if you look at the ugly main page with the two lines leading you to the administrative and mydns logins, it will become apparent that I'm an OS guy, not a web designer. :)

    It probably wouldn't be that hard to add a plugin to the agent for doing this. Want to work on it?
    Last edited: Feb 20, 2009
  8. tom2501

    tom2501 New Member

    After importing LochDns into my esx i run it, changed the default password, started network configuration, put all the IPs in, and after hitting Save i get:
    "Error: <ProtocolError for admin:******@localhost:8004/xmlrpc/:500 Internal Server Error>

    thanks for any help
  9. michaelkjohnson

    michaelkjohnson New Member

    debugging 500 ISE

    Was this in the initial text-mode UI?

    If you log out and log back in, does the error clear?

    Can you log in as root on another virtual terminal (alt-f2)?

    If so, can you please get the contents of /var/log/raa/* and attach them to an issue in the rPath issue tracking system at in the "Platform Agent" product? (Please check to make sure that they do not expose your passwords first -- if there's a bug, a traceback might include a password, so search for your password and replace it with something like XXXX before posting it.)

    My first guess is that the bug starts with a typo in an IP address or something like that, but I could be completely wrong...
  10. tom2501

    tom2501 New Member




    The error was caused by unreachable gateway. I've put that VM in isolated network, cause i wanted to configure it first. When i put it in my server VLAN it went smoothly.

    So i think the case is closed.
  11. michaelkjohnson

    michaelkjohnson New Member

    Thanks -- issue filed

    Thanks for investigating. I'm glad that the issue is not blocking deployment -- but it still sounds like a bug, so I have opened an issue report RAA-1696 in the rPath issue tracking system.
  12. preterition

    preterition New Member

    New MyDNSconfig

    After 3+ years, There is an UPDATE! WHooo hoooo. I'm excited can you tell.


    MyDNSConfig 3.0.1 released

    This is a totally new MyDNSConfig package with a new theme. It supports features introduced with MyDNS-NG and fixes several bugs. [Download] [Release Notes]


    MyDNSConfig 1.1.0 released

    This MyDNSConfig release fixes several bugs in the Authentication system and adds a new interface theme.

Share This Page