mysql checkbox missing

Discussion in 'Installation/Configuration' started by mishko, Feb 15, 2008.

  1. whimboo

    whimboo New Member

    Till, my mySQL version is "mysql Ver 14.12 Distrib 5.0.32, for pc-linux-gnu (x86_64) using readline 5.2". While I was searching for ENGINE meanwhile I read that TYPE is only an alias right now for ENGINE and will be obsolete in the future. So no idea, why exactly these tables show the upgrade problem. I did a diff between the database structure of .19 and .21 to see which tables have been changed.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I changed the tables back to "type" in the sql dump in SVN. Maybe there is some kind of incompatibility in some mysql versions.

    Maybe you can try to make a new empty mysql database and then load the ispconfig mysql dump into the database with e.g. phpmyadmin and check if you get any errors.
  3. whimboo

    whimboo New Member

    Importing the db_ispconfig.sql from the .21 release doesn't show up any error when doing the import via phpmyadmin. Perhaps it fails while upgrading the database and having different types for these tables? I'm not able to verify this on my box due to it's a production system and no test installation is available atm.
  4. cambo

    cambo New Member

    I had the same problem with no Mysql checkbox and no databases showing in the options tab. I went from 2.2.6 to 2.2.21.

    Falkos "replace doctype 1013 fix" solved the no checkbox problem.
  5. cambo

    cambo New Member

    I also had to do this:

    ALTER TABLE `isp_isp_web` ADD `web_ruby` char( 1 ) default NULL;

    Seems to me that the suggestion that the sql is buggy in a previous post may be correct.

  6. whimboo

    whimboo New Member

    Till or Falko, will this be fixed in the next version?
  7. falko

    falko Super Moderator ISPConfig Developer

    It'S already fixed in SVN according to Till.
  8. cbakken

    cbakken New Member HowtoForge Supporter

    Hi, I had the same problem when upgrading to 2.2.21, and for me the tips in this thread also fixed (most of) the problems.
    I say "most of" because one problem still persists, and that is that the database listings in ISP Site -> Options for each site is gone.

    Is there a fix for this problem too?

    EDIT: This applies only to existing databases, newly created ones shows up like they should. And of course the problem is because I had to recreate all site databases in PhpMyAdmin since my upgrading to ISPConfig 2.2.21 was done at the same time as moving to a new web server.
    So I'll rephrase my question: Is there a way which I can make DB's created in PhpMyAdmin visible under ISP Site -> Options?

    Last edited: Apr 7, 2008
  9. cbakken

    cbakken New Member HowtoForge Supporter

    I found a solution for the problem in my last post.

    I created new databases with the same password as the original ones, and altered db names and users in table isp_isp_datenbank so they became the same as the originals.

    Afterwards I deleted the newly created db's.

    It works like a charm now, but does anyone see a problem with this approach?

  10. falko

    falko Super Moderator ISPConfig Developer

    Should be ok.
  11. cambo

    cambo New Member

    Still got the same problem!?!

    Hi Falko
    Just wanted to let you know that there is still a problem with this doctype issue.

    I have just done a fresh install, Perfect Mandriva Spring 2008, and ISPConfig *.22 on new hardware.

    I got the error 'The requested document type does not exist.' in Management -> Settings and ISP Manager -> Reseller

    I fixed that by copying my doctype table over from another server that I had already upgraded to .22 (also had the same problem when upgrading but managed to fix it).

    There is no Mysql checkbox when adding a Reseller, but it allows me to put the number of databases. I have put 30 there.

    When I try to add a new website, the Mysql checkbox is there, which I tick and select 1 in the amount field. but when I go to the next page, it says 'not allowed to add mysql databases'

    I tried the replace doctype 1013 fix on page 3 of this thread, still no joy.

    I tried a re-install, same result.

    Any suggestions??

  12. falko

    falko Super Moderator ISPConfig Developer

  13. cambo

    cambo New Member

    Hi Falko
    I thought I had but when I checked it was utf8.
    I think what happened is that skip-networking wasn't in my.cnf so I forgot to save to change it.
    I have changed it now and restarted mysql. It all seems to be working.
  14. luchs3

    luchs3 New Member

    I've had the problem a few weeks ago.
    The doctype crack helped, but suddenly I have the same problem again and the doctype Statement doesn't help anymore.

    When I go the a web ISPconfig deletes its Database.
    I allready lost a few, and I can't install them again.
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Please download the latest ISPConfig version and run the setup script to update your installation. Make sure that you have the correct latin1 chracater set for ISPConfig set before you run the update.
  16. luchs3

    luchs3 New Member

    I got it back, it disappeared when I disabled the frontpage extensions.
    Is this bug now fixed?
    Which latin1 charset has to be set and where?
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    I'am not aware that ther was such a bug in the last few versions.

    Please read this thread, it is explained a few posts above your post.
  18. luchs3

    luchs3 New Member

    phpmyadmin says: MySQL charset: UTF-8 Unicode (utf8)

    I can't find default_charset in my (ubuntu)
  19. pasha

    pasha New Member

    Same issue

    Hi guys,

    I am having the exact same issue as described. I had one of my servers fail so I installed centOS 5.3 on a new system installed ISPConfig on the new server then copied over all the config files including the databases. First thing I noticed was the missing mysql checkbox in the site form, and in the reseller form. I was ok with that for the time being, until today after trying to setup a new domain, after saving it wiped out 2 of my databases, after looking the recycling bin I found it there, restored it but it did not restore back to disk or anywhere that I could find. It is not longer in the Recyling Bin or anywhere else. Luckily I had a backup so I was able to restore it from backup, but I am thinking this will happen again if I add another site. Any input is helpful.


  20. cambo

    cambo New Member

    missing mysql

    Hi Paul
    Yes I found that will be the case. If you edit one of your current sites with ISPConfig not having the mysql checkbox available, it will remove your current db(s) associated with that site, so you need to be careful until you resolve this issue.
    There is a resolution, as I had the same problem, but have fixed it now.
    See my 2 posts on this page and refer to Falkos post here -
    That's what solved my "no mysql checkbox" issues.

Share This Page