mysql checkbox missing

Discussion in 'Installation/Configuration' started by mishko, Feb 15, 2008.

  1. pasha

    pasha New Member

    New Error

    Thanks for your reply Cambo,

    I tried following the two links you posted there... I am going to review once more to make sure I did not miss anything but after deleting doctype_id 1013 out of the db and then re-inserting as Falko suggested in the post you referred me to, when I try to edit any site in ISPConfig now I get "The requested document type does not exist".

    Thanks for your help thus far!

  2. pasha

    pasha New Member

    One Step Closer

    Ok so after hours of digging through the ispconfig php files, I believe to have tracked the problem to the following:

    line 75 in ispconfig_doc.lib.php: return unserialize($row["doctype_def"]);

    the result of that call returns false. The line the calls that function (edit.php somewhere around line 455) expects a document object to be returned.

    It looks like the doctype_def does not unserialize back into the object correctly or as expected anyway, I do not know how to fix this yet, but I will see if I can find a good way to compare what used to be with what is now and find the breaking point.

    Let me know your thoughts.

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    This happens when either the doctypes has been loaded manually into the database with the wrong charset or the database charset is set to a wrong value. the database charset has to be latin-1, utf-8 is not supported and will cause the error that you describe.
  4. pasha

    pasha New Member

    Problem goes on

    Hi Till,

    You are probably right about that. Minutes after I posted my last message, I thought I would try a different aproach. Instead of pasting it via ssh -> mysql client into the database, I pasted it via phpmyadmin and that made my error go away, the very disappointing part is thought that I am right back to square one. I edited a site, mysql option still no there, and when I hit save it removed it's database files on the filesystem... not sure what else to try.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Do not do this manually, it has to be done by the ispconfig installer! Just make sure that your database has the correct charset and then run the setup script from the latest ispconfig 2 version again to let it repair the doctypes.

Share This Page