MySQL headers not in /usr directory - I just installed them!

Discussion in 'Installation/Configuration' started by PorkFat, Dec 28, 2005.

  1. PorkFat

    PorkFat New Member

    ISPConfig is giving me a headache! I have Madriva 2006 and I have installed all the prerequisites properly using urpmi. But ISPConfig keeps complaining that the mysql headers aren't in the /usr directory. The installation program doesn't put them there, of course they're not going to be there! I have mysql server, client and devel installed but it's still not good enough.

    What am I supposed to do? I've urpmi EVERYTHING that's required but I need the headers in the /usr. Please help!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this a 32bit or 64bit linux installation?
  3. PorkFat

    PorkFat New Member

    This is 32bit.

    Another thing is I could not do certain things in the Howto on my system:

    For one, I cannot run mysqld unless it's in safe mode, or I use the "service mysqld start" command. The How to says to just type "mysqld" to make it work. But it doesn't work. It gives some error about reading a manual to learn how to run mysql as root. So I just ran the service.

    I also can't do "/etc/init.d/network restart" because "network" is not even in that directory! I rebooted instead.

    Also, the way they have this step: "Restart Apache: /etc/init.d/httpd restart" doesn't work! I have to type "httpd -k restart"

    Why would my system be so different with the same operation system installed?

    I've verified mysql installed properly, I've logged in and seen the default database is available so it's good to go. It just didn't put it's headers in /usr. I don't know how to do it.
    Last edited: Dec 28, 2005
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you done all the steps in the howto as root user? Dont use sudo or any other user.
  5. falko

    falko Super Moderator ISPConfig Developer

  6. PorkFat

    PorkFat New Member

    That's exactly what I used to get this far! Unfortunately, it's no help when I do everything EXACTLY as the howto says, but it doesn't end up right.
  7. falko

    falko Super Moderator ISPConfig Developer

    Maybe you made some typos somewhere? Because that is exactly the setup I used, and I never had problems with it...
  8. PorkFat

    PorkFat New Member

    I had no typos. I did however have an already operational mysql running before I tried to install ISPConfig. I rebooted and voila! The headers were where they were supposed to be and the install went swimmingly until...

    Whammo enter your MySQL database:

    I enter: mysql
    But the damn thing doesn't accept my password!

    It of course destroys the entire half hour setup and kicks me out. SON OF A!

    I test my mysql password out right after that:

    mysql -u root -p
    enter password: *****

    Bingo, starts right up. So why would ISPConfig not take it? There's no special characters, just a simple word.

    This install is killing me! Taking up a half a day and counting and still starts back to ground zero.

    *edit* Apparantly I messed this one up myself upon second look. I should have said localhost then root, then password. Another 30 minutes to go until I get back to where I was...
    Last edited: Dec 29, 2005
  9. PorkFat

    PorkFat New Member

    Man this sucks! Now the install script thinks I'm installing an upgrade and it's calling on the WRONG password I supplied the first time and the ./setup script is completely blowing up with only 4 lines left. It tells me the install went fine even though it threw 4 huge errors right before. It can't log in to the DB because it's trying to use the wrong password and now I have to hunt down where it's storing it to change it...

    Anybody know where it's kept?

    ISPconfig is looking for, but it's not there sine the first install didn't work. Now I can't reinstall it because it was partially installed and it thinks it's upgrading. So it looks for and it isn't there then it errors out and the cycle begins anew...

    Anyone know where I can get a file and edit it with the correct db_name and password?

    *edit* Ah, this is EXACTLY my problem. I hope it helps my errors:
    Last edited: Dec 29, 2005
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Please read the installation manual. It is described there which directories have to be removed to reinstall ISPConfig on an unfinished prior installation.

Share This Page