mysql password problem

Discussion in 'Installation/Configuration' started by brianetilley, Dec 7, 2005.

  1. brianetilley

    brianetilley New Member

    So close...But it choked at the mysql password. I entered 'localhost' for server.
    'root' for user...and the mysql password I created when installing the base system. Should I have used 'debian-sys-maint' for user? Should I use 'ispconfigdb' for database. Should I enter the static IP address I used during the base install for ISPConfig web? Please explain the proper syntax for this step. Thank you.

  2. falko

    falko Super Moderator Howtoforge Staff


    No, root is correct. Make sure you make no typos when you type in the password.
    Any name you like and that doesn't exist as database yet.

    As host and domain you type in the FQDN you want to use for the ISPConfig web interface (normally your servers hostname). You have to make sure that the FQDN exists in DNS and points to your ISPConfig server, and your firewall must allow pings to the server.
    If you don't have a DNS record for your FQDN, you can leave the host empty and enter your system's IP address as domain.
  3. brianetilley

    brianetilley New Member

    I started from the beginning...and got the same results. The password choked. This is the error message:
    ERROR:1045: Access denied for user:'root@localhost' (Using password:YES)
    ERROR: The provided MySQL password is wrong! The installation routine stops here! Is there a way to reconfigure/edit the MySQL password? Thank you...

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have any special chars in your password? Did you have a look at the debian howtos for ISPConfig? It is described there how you can set the an mySQL password:

    mysqladmin -u root password yourrootsqlpassword
  5. falko

    falko Super Moderator Howtoforge Staff

    If you have set another MySQL password before, the command to set a new password would be:

    mysqladmin -u root -p<current_password> password <new_password>
    (there's no space between -p and <current_password>!)
  6. brianetilley

    brianetilley New Member

    Changing the password worked. I have tried to find some info about the use of special characters in MySQL passwords with no luck. Do you have a link to the appropriate docs? After a successful install of ispconfig I can not login to the ispconfig interface. Do I need to install a browser on the server to access the interface? Or do I use the IP address I used on the base install for a DNS lookup? Thank you...
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please describe it a bit more detailed. Wich uRL did you use? Is it the URL that you entered during the setup? Did you use username: admin password: admin?


    No. Only if the Server domain is not propagated in DNS yet.
  8. brianetilley

    brianetilley New Member

    These are the values returned by the system;
    dns domainname:localdomain
    hostname --fgdn:localhost.localdomain

    I used a staticIP address given to me from my ISP when installing ISPConfig. I tried using Lynx and it logged me in, I entered 'admin' for user, but it would not accept 'admin' for password...the cursor jumps out of the field. Do I need to set the nameservers on my domain registrar's site to point to the static the static IP the IP of the DNS set up by ISPConfig? I apologize for my ignorance of these issues...the more I research this the more confusing it gets...but I know I am only a few keystrokes away from success. Thanks for the patience.

  9. falko

    falko Super Moderator Howtoforge Staff

    When you try to log in, you have to use the same URL that you typed in during setup and that is now in the file /home/admispconfig/ispconfig/lib/
  10. brianetilley

    brianetilley New Member

    From the file ''
    ["server_url"] = "";

    When I try to login from another machine with URL '' I get a not found error.
    When I use the IP address I get a connection refused error.

    Using Lynx on the server I get 'SSL error: Can't find common name in certificate -Continue ? (y). When I continue the login page comes up as follows;

    Here you can login:
    Username:_ _ _ _ _ _ _ _ _ _
    Password:_ _ _ _ _ _ _ _ _ _

    Using 'admin' for both fields returns returns another SSL error: Can't find common name in certificate - Continue? (y)
    refresh URL not absolute

    I hope this helps....

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    This seems to be an DNS problem.

    Are there any firewalls / routers between your workstation and server.

    The first error is normal because its a self signed certificate.
    The second error means that you have not entered a common name for the SSL cert during ISPConfig installation.
  12. brianetilley

    brianetilley New Member

    My workstation is running SuSE 9.3 and has the same ISP as the server. There is no firewall/router on either machine. I entered my name in the 'common name' field of the certificate (from the example). I have to leave for 3 hours...

  13. falko

    falko Super Moderator Howtoforge Staff

    This is what I found out:

    There's no A record for! You have to create that first.
  14. brianetilley

    brianetilley New Member

    Could you please give me a link to the documentation that explains how to set up the "A" record. Thanks..

  15. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no documentation especially for A records.

    Go to DNS Manager, open the SOA for the domain, go to the records tab and add a new A record. As hostname you enter www and as IP you enter your IP address.
  16. brianetilley

    brianetilley New Member

    I can not access the ispconfig interface, so any changes I make must be from the command line. Please tell me what file to edit...and the correct syntax. Thank you...

  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Open the file, replace the URL with the IP of your server, then you can access ISPConfig. If you have not accessed ISPConfig yet, your server can not be authoritive for your domain. So you need to create the A record at your domain registry.
  18. brianetilley

    brianetilley New Member

    Do you mean I should change the nameservers of my Domain Registrar to the IP address in the file (without the port 81). Is this the same IP address used by the DNS server installed with ISPConfig?

  19. till

    till Super Moderator Staff Member ISPConfig Developer

    No. You should buy managed DNS at your domain registrar for your first domain. Then add an A record (at your domain registrar) that points to the IP of your server. Then you can login to the ISPCOnfig controlpanel.

    For all other domains that you buy later you can use the DNS manager in ISPConfig to create and manage the DNS records.
  20. falko

    falko Super Moderator Howtoforge Staff

    The authoritative name servers for are and That's where you have to create the DNS records for your domain ("Managed DNS").

    Also have a look here:

Share This Page