Nameservers & DNS configuration

Discussion in 'Installation/Configuration' started by empi, Sep 20, 2016.

  1. empi

    empi New Member


    I have followed guide to setup own nameservers. I have debian server with latest ISPconfig on both virtual servers. First is with IP (here is full websererver and it's master). The second is with IP I have correctly configured A records on this domain and my domain provider registred nameservers to global registry, but the nameservers still doesn't work.
    I have setup these nameservers on domain for testing purposes, but if I check the domain DNS on some online tools, nameservers doesn't work. Where can be the problem?

  2. Bacon8tor

    Bacon8tor New Member

    Hey I came here to post a problem I am having with the Centos 7.2 - ISPConfig Tutorial , I have followed the tutorial exactly about 6 or 7 times and everytime DNS is not working. I am using this on a test network as well. I have found out so far that whenever I use the Zone wizard to add a new domain it then outputs the zone file as , which i also found was something new with ispconfig 3.1 .
    if your using Centos check /var/named and see what the zone file is called. if it added a .err that means that it found a syntax error with the file. Unfortunately I couldnt find anything wrong or fix the problem.
    But I have tried then using Ubuntu16.04/ispconfig3.1 and that tutorial and the DNS works as expected and I do not have the same issues.
  3. empi

    empi New Member

    I found where can be problem. I cannot access to internet from my ns2 server. If I ping I don't recieve anything. I compared etc/network/interfaces on both servers but they are similar expect ip address. So where can be problem? In jobqueue is one week old job Action - update, DB tabl - server, so probably it cannot be completed, because of internet connection
    Last edited: Sep 22, 2016
  4. What are the nameservers you have used in resolve.conf?
  5. empi

    empi New Member

    In resolv.conf I have nameserver on both servers (in main server and in ns2 server, which dosen't work, too) I can connect over ssh to this ns2 server but ping command does nothing
    Last edited: Sep 25, 2016
  6. What is the output of ping command? You are able to ssh ns2, so did you check if ping is disabled for main server?

    If not then disable the firewall then try. Also try to use google's nameservers,
  7. empi

    empi New Member

    I have found, where is the problem. I manually run /usr/local/ispconfig/server/ on ns2 server and it returns an error: ERROR - Replication failed. Error: (sys_ini) in MySQL server: (localhost) Unknown column 'default_logo' in 'field list' #.....

    So I manually alter that column in that table, but after sucessfully completed command, I run again and there is another error. So that means, I have different version of dbispconfig table. How is this possible? Can I update dbispconfig table on ns2 server to ISPconfig 3.1dev, which am I using on main server?
  8. florian030

    florian030 Well-Known Member HowtoForge Supporter

    All servers must use the same ispconfig version
  9. empi

    empi New Member

    OK thank you Florian, now it seems it is working :)

Share This Page