Newbie here, needs reassuring...

Discussion in 'General' started by CorrosionX, Oct 24, 2005.

  1. CorrosionX

    CorrosionX New Member

    Hi people

    I just built my web server using the Perfect Ubuntu 5.10 setup, and I've got some small stuff i want to clarify just to reassure me.

    The server will eventually be installed on my office LAN and it will have a static IP and port 80 open. Right now it's at home on a dynamic ip and port 80 closed.

    I have done everything in the tutorial and I installed the PhpMyAdmin package also.

    I created a couple of test sites on it, and the only one I can access by typing (its local IP) and I get a ISPconfig default index page and nothing else.

    The Phpmyadmin asks me for user/password but none of my ISPConfig passwords work.

    I plan to bring the server to the office and set up port forwarding 80 to that server. But then what should I do?

    I know I'll have to point my domain names to the IP of the nameserver (which I think is gonna be the same server, right?)

    Will ISPconfig then know what domain name is requested and show the appropriate site?

    Looking forward to being helped, thanks!

    P.S.Is there some sort of "Going Live" tutorial for ISPConfig out there?
    Last edited: Oct 24, 2005
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You cannot login with the ISPConfig passwords to phpmyadmin. Use your root mysql username and password as admininistrator account and the passwords / usernames you entered when you created a new database in ISPConfig for the client databases.

    Forward your domains to that server.

    Its the same if you want to use the nameserver that comes with your ISPConfig setup.

    Yes, because the vhosts are name based.

    I dont think so.
  3. CorrosionX

    CorrosionX New Member

    Wow quick reply... thanks!

    Ok so I guess there's not much more I can do right here so I'll install it at the office and test it from there...

    I understand I won't be able to access any of the ISPconfig-made websites locally until the domain names resolve correctly, right?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There is a solution, you can add the IP and domain to the hosts file on your workstation (Yes even windows has this ;) )
    The form is:
  5. CorrosionX

    CorrosionX New Member

    closer, warmer....

    yup pretty cool trick i forgot all about it.

    Now I get the internal server error when I try to access any subdirectory, I guess it's a question of permissions right?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    How have you uploaded the website Data, with FTP? Does the directories have execute permissions?
  7. CorrosionX

    CorrosionX New Member

    Yes and yes
  8. CorrosionX

    CorrosionX New Member

    Not fixed!

    Hello people.

    I still can't access any subdirectories and all permissions look a-ok (execute and read for the world).

    Also what are the ports that should be open for the DNS to work?

    Thanks in advance
  9. falko

    falko Super Moderator Howtoforge Staff

    Can you post the output of
    ls -la /path/to/one/of/those/subdirectories

    Port 53 TCP and UDP.
  10. CorrosionX

    CorrosionX New Member

    root@www:/var/www/ ls -la
    total 48
    drwxrwxr-x 4 web2_arconsultant web2 4096 2005-10-26 12:17 .
    drwxr-xr-x 8 web2_arconsultant web2 4096 2005-10-23 14:47 ..
    drwxr-xr-x 15 web2_arconsultant web2 4096 2005-10-23 14:30 catalog
    -rw-r--r-- 1 root root 16139 2005-10-24 12:47 .catalog
    drwxrwxr-x 2 web2_arconsultant web2 4096 2005-10-23 14:15 error
    -rw-rw-r-- 1 web2_arconsultant web2 1329 2005-10-26 12:17 index.html
    -rw-r--r-- 1 root root 12288 2005-10-26 12:17 .index.html.swp

    Allright DNS is ok I am able to connect to the server (which is now storaged at the office), I forward port 53 UDP&TCP on the Linksys router.

    Now when I tried to do the nameserver thing at the registrar they ask 2 nameservers. I'm gonna have them both on the same machine... Can you link me to any place with a tutorial about this?

    It's looking good we're all excited here :)
    Last edited: Oct 26, 2005
  11. falko

    falko Super Moderator Howtoforge Staff

    You can only have one Bind installation on port 53, so you have to make your registrar accept the same nameserver twice.
  12. CorrosionX

    CorrosionX New Member

    Yes actually my registrar let me make nameservers to point to my IP so that's taken care of.

    What do you think about the permissions problem?
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you tried to restart the apache webserver?

    When you enter your domain, are you sure you get files from the root directory of that domain, maybe you get a file from another default location. Please put a custom HTML file in the webroot of this site and try if you can get it in the browser.
  14. CorrosionX

    CorrosionX New Member

    Yup I made a custom index.html for each subdir and the domains resolve correctly (with the IP address of the server in my hosts file)

    Now i think I've got some leftover .htaccess file in there and I'm getting through the permisisons problems...

Share This Page