No access when creating new sites

Discussion in 'General' started by kardac, Jul 22, 2010.

  1. kardac

    kardac New Member

    When i try to creat new clients and sites, i cant browse or access the folders in /var/www/clients/clientX/webX. I get Permission denied.
    I cant connect with the FTP accounts for these sites either.

    First I experienced this when creating a new client and site, but I have also tried creating new sites at already existing clients and the same problem occur.


    I have checked the ownership on the siteX and webX folder and it looks the same as the others that are functioning.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to access the websites by domain name. So to acchees them, oben a webbrowser and type the domain name into the URL field and hit return. You can not access the sites by entering the path on the harddisk into the browser URL field.

    Regarding the FTP users:

    1) Are there any jobs left in the jobqueue in the ispconfig monitor?
    2) And are there any errors in the system log in the ispconfig monitor?
    3) Which tutorial did you use to install the server?
  3. kardac

    kardac New Member

    Maybe my bad english is messing things up :)

    What i mean is that when i try to access the new sites I created with SSH or FTP protocol, I cant connect.

    When i use putty to access my server and tries to list files and folders i get this result from the server.
    [email protected]:/var/www/clients/client1/web6$ ls
    ls: cannot open directory .: Permission denied
    Ive checked the parent folder for ownership and chmod settings and get the following result.
    administrator[email protected]:/var/www/clients/client1$ ls -dl web6
    drwxr-x--x 6 web6 client1 4096 2010-07-22 10:12 web6

    All earlier sites I have created runs fine, the server has been up for maybe 2 months.

    I have installed according to the Ubuntu 10.04 LTS Ultimate server guide on this site, I have installed two other ISPconfig servers earliers with other versions of ubuntu and ISPconfig with the matching tutorials so im not a first time user even though im still somewhat of a rookie on linux.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It is ok that you can not access the websites from a user account named "administrator" as this user has no admin permissions on a Linux system. The user that is able to access all files in linux is named "root" and not "administrator" like in windows. If you want to access the sites without using the ssh user of a site, run:

    sudo su

    and when you run then:

    cd /var/www/clients/client1/web6

    you will be able to access the data of this website.

    To be able to help you with the FTP access problem, answer my questions from post #2.
  5. kardac

    kardac New Member

    I did check the other sites and could do a ls in the previously created sitefolders, but now i realized i did an aptitude update before checking this and activated sudo su before running the update and so had root access before checking the other folders... So, that problem is no problem and expained by your post :)
    Thanx for getting my things straight :D

    1= Nope
    2= Nope

    Actually, i once again removed the client and site i created and started over and this time it worked.... :/ Sorry for taking your time with this.

    I guess the problem was that i did to many things at the same time trying to find the problem.

Share This Page