No PHP MySQLi functions available. Please ensure that the PHP MySQL module is loaded

Discussion in 'Installation/Configuration' started by p045, Apr 29, 2019.

  1. p045

    p045 New Member

    First, I have read the post "Please read before posting".

    I am sure the error I am getting is simple enough not to run the analyzer, but sadly not simple enough for me to fix it.

    I have a fresh CentOs 7.6 VPS from DigitalOcean, and these are the only command I run in it.

    These are the command I run
    # Security Components
    yum install fail2ban jailkit
    # Database Components
    yum install mariadb-server mariadb-libs mariadb
    firewall-cmd --zone=public --permanent --add-port=mysql/tcp
    firewall-cmd --reload
    # Web Components
    yum install nginx pure-ftpd certbot
    systemctl enable nginx
    systemctl enable pure-ftpd
    firewall-cmd --zone=public --permanent --add-port=http/tcp
    firewall-cmd --zone=public --permanent --add-port=https/tcp
    firewall-cmd --reload
    # Mail Components
    yum install postfix dovecot postgrey spamassassin amavisd-new getmail roundcubemail mailx svn
    systemctl enable dovecot
    systemctl enable postfix
    systemctl enable postgrey
    systemctl enable amavisd
    firewall-cmd --zone=public --permanent --add-port=imaps/tcp
    firewall-cmd --zone=public --permanent --add-port=pop3s/tcp
    firewall-cmd --zone=public --permanent --add-port=smtp/tcp
    firewall-cmd --zone=public --permanent --add-port=smtps/tcp
    firewall-cmd --reload
    cd /usr/share/roundcubemail/plugins
    svn co .
    cp ./ispconfig3_account/config/ ./ispconfig3_account/config/
    # DNS Components
    yum install bind
    systemctl enable named
    firewall-cmd --zone=public --permanent --add-port=53/tcp
    firewall-cmd --zone=public --permanent --add-port=53/udp
    firewall-cmd --reload
    cd /root
    tar xfv ISPConfig-3.1.11.tar.gz
    cd ispconfig3_install/install
    php install.php
    And you can see at this point, after I run the install, choose language, standard, then I get the error:
    No PHP MySQLi functions available. Please ensure that the PHP MySQL module is loaded
    So, what is the solution to this? I am thinking I should maybe install php7.3 along with the mysql-ext, but coming from plesk, cpanel, the php, nginx install is usually handled my the control panel, all the cpanel asks for is a fresh VPS.

    So in this case, I don't want to install anything that might be installed by the cpanel itself.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You missed installing a lot of prerequisites. Please follow the installation instructions from beginning to end (all 3 pages):

    That's different when using ISPConfig. ISPConfig uses the software packages of the Linux distribution, so you benefit from updates directly and does not replace them as Plesk does.
  3. p045

    p045 New Member

    Ok, I gave the link you provided a try, and I have encountered some errors, and this one is the where I have stopped, because it simply won't work.

    [root@server ~]# mount -o remount /var
    mount: /etc/fstab: parse error: ignore entry at line 25.
    mount: /var not mounted or bad option
           In some cases useful info is found in syslog - try
           dmesg | tail or so.
    [root@server ~]#
    Here is the log from the msg

    I followed and wrote down every line of command on a fresh VPS from digitalocean.

    I don't really like to complain on a quality of opensource software, which is basically given for free, but please try the commands yourself first before sharing them. If the VPS was old, had issues and this guide didn't work, I would understand, but this is just a new VPS I created solely for installing IPSConfig and the fact the guide does not work and wastes time is really upsetting.
  4. p045

    p045 New Member

    Actually never mind, if it is hard to finish the first page instruction without errors, it's most likely impossible to complete all the three pages. Just make sure to try and update the manual yourself, so no one wastes 2-3 days of pain
  5. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    It seems silly to blame the instructions when you clearly had not followed them, or the quality of the software, which you haven't installed and used at that point in the setup. (As for the perfect server guides, I have not tried the CentOS ones myself but have followed the debian instructions several times and they worked quite well. I suspect the CentOS ones would be of similar quality.)

    This means you made an error in your fstab. What is on line 25?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The CentOS guide works fine, used it a few days ago. Simply copy&paste of the commands works. As @jesse pointed out, you have an error in your fstab file now, if you post it then we can try to help you with that, the actual file content depends on your initial operating system installation. Regarding your initial problem, @jesse summed that up as well. If you do not follow install instructions then you should not expect to get a working setup and you can not blame the instructions which you did not follow nor the software you installed for that.

    Sidenote: Debian and Ubuntu are much easier to install than CentOS, you should consider using them.

Share This Page