novice question.. I gave wrong IP for install, how to change?

Discussion in 'Installation/Configuration' started by amoswright, Jan 11, 2006.

  1. amoswright

    amoswright New Member


    I just completed an install of ISPConfig on fc4 as described in "the perfect set up". I thought that things had gone well, untill I tried to log in on port 80... no go, connection timmed out... then I realized that I'd made a mistake in assigning the IP at the end of the ISPConfig install (ISPConfig Web address). How can I change this?

    Again, i think that things went well otherwise.. i couldn't get any of the "postconf -e 'smtpd_sasl_local_domain =' " and similar commands to work, even though postfix did install, but thought that this wouldn't matter much since i'm not really interested in setting up mail.

    Stoopid to make such a moronic mistake in the first place... I'd love to know how to change the ISPConfig Web address.

    Thanks Much!
  2. falko

    falko Super Moderator Howtoforge Staff

    First, you must login on port 81, that's the port ISPConfig uses.
    You can change the URL in /home/admispconfig/ispconfig/lib/ You might also have to change the address in /root/ispconfig/httpd/conf/httpd.conf and restart ISPConfig then:
    /etc/init.d/ispconfig_server restart
    Why do you think the postconf commands did not work? Did you get any errors?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you execute the commands as root user?

    These commands did not output anything, if you had not got an error, the comands executed successfully.
  4. amoswright

    amoswright New Member

    Hi and thanks for the speedy reply! Thanks Falko and Till!

    I'll clarify what I had tried and where I went wrong (I believe):

    In setting up my system, I had installed ISPConfig on a PC that is connected to a Linksys router. I had given the PC two static IP's as described in "perfect set up", and During the final install of ISPConfig, I listed as the "address of the ISPConfig web".. Now, I have a static IP from our service provider,, and once I realized the complications that would arise with port forwarding on the router etc., thought to put the server outside of the router (by way of connecting the PC and the router to a small switch). Thus, I hoped to assign our outside static IP to the server with ISPConfig, and have the router on DHCP... Does this set up work, and if so how would I change that IP setting in ISPConfig? I looked in the files that were suggested, and saw how to change the URL such as "", but not the underlying IP number, did I just miss it?

    On other question of executing the postconf commands, I did get an error, "command not found". I was logged in as root. Oddly, now the command works... Is it too late to complete this section of the "perfet install" directions, after ISPConfig is set up?

    Thanks agian,
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    For this kind of setup you need 2 statix IP's from your provider. One for the server and one for the router.

    You can rerun the postfix setup part.
  6. amoswright

    amoswright New Member

    Hmmm... so, back to setting it up behind the router then... was I correct in providing the local static IP (ie or as the ISPConfig Web IP?

    I guess I'm not sure of the settings for the final part of ISPConfig, and how to change them now, after the fact...

    If I assign the router the the outside static IP, then would these settings work:
    Please enter your MySQL server: localhost
    Please enter your MySQL user: root
    Please enter your MySQL password: (psswd)
    Please enter a name for the ISPConfig database: ispconfigdb
    Please enter the IP address of the ISPConfig web:
    Please enter the host name: www
    Please enter the domain:
    Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system: http

    And then... I need to do something to the router to forward the request to the internal IP?

    ...Trying to get a server set up so kids at our teen center can do web design on our newly donated computers... Am I getting close?

    Once again, thank you!!!!
  7. falko

    falko Super Moderator Howtoforge Staff

    As Till said, you would need a second static IP address for this.

    So I guess you're setting up your server behind the router in a local network. My comments are for this scenario.
    This is all ok.

    You have to forward port 81 from your router to your ISPConfig server.
  8. amoswright

    amoswright New Member

    Hi and Thank YOU!

    It seems to be working! ...this is a wonderful resource, thanks to all for making it so, and to Falko and Till for answering my questions above!

    ... now that I have it installed I do have one issue: it seems that in the admin pannel the frame to the right (where info and options are displayed) doesn't seem to be loading. Sometimes if I click to something else it will flash for a second, otherwise it hangs and does nothing...

    I suppose this may be another thread....

    Thanks again!
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look at this thread, i guess your problem is related to the "missing images" issue.

Share This Page