on problems with Openbravo ERP on Ubuntu 8.10

Discussion in 'Installation/Configuration' started by ilyass, Mar 24, 2009.

  1. ilyass

    ilyass New Member


    I tried to install openbravo ERP on Ubuntu 8.10, so I followed this tutorial:
    but when I introduce the command ./OpenbravoERP_2.40-linux-installer.bin a warnig message shows up telling that :

    Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so
    /usr/lib/gio/modules/libgiogconf.so: wrong ELF class: ELFCLASS64
    Failed to load module: /usr/lib/gio/modules/libgiogconf.so
    /usr/lib/gio/modules/libgioremote-volume-monitor.so: wrong ELF class: ELFCLASS64
    Failed to load module: /usr/lib/gio/modules/libgioremote-volume-monitor.so

    I ignored this message and I continued the installation but when it almost finished a warning message appears again telling that :
    Problem running post-install step. Installation may not complete correctly
    Error running /usr/share/ant/bin/ant compile -Dtab=xx war -logfile /opt/OpenbravoERP/installation_logs/04war.log : child process exited abnormally

    And the file openbravo.war did not exist neither in /var/lib/tomcat5.5/webapps nor /opt/OpenbravoERP/Appsopenbravo/lib

    Can somebody help me please?
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    uname -a
  3. ilyass

    ilyass New Member

    Here is the out put of uname -a:

    Linux ribatis-laptop 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009 x86_64 GNU/Linux

    I think that the problem have a relation with ubuntu 64 bits, so i tried to download the package that contains the libraries libgvfsdbus.so, libgiogconf.so and libgioremote-volume-monitor.so from http://packages.ubuntu.com, I took the one with i386. I unpacked the package on my desktop, so that created usr folder, I copied the /usr/lib from the desktop to /usr/lib32. I tried to run OpenbravoERP but I got the same problems again.
    Any ideas please?
  4. falko

    falko Super Moderator ISPConfig Developer

  5. ilyass

    ilyass New Member

    It's working perfectly.

    Thank you very much falko.

Share This Page