Opensuse 11.3 ispconfig3 ssh, sftp, issues

Discussion in 'Server Operation' started by wildnux, Nov 29, 2010.

  1. wildnux

    wildnux New Member

    I set up a lamp server following the guide for a perfect opensuse server. But I had a few issues. I want to solve them one by one, so i am discussing only one here. I will start a new thread for other problems. I can log in to the machine perfectly with a real user name and password with ssh,or winscp (SFTP protocol), but the virtual users, that were created by ispconfig cannot log in via winscp with sftp protocol. It has to have 'scp', selected. Also my friend had a mac and he was trying to log in to the machine, but could not because none of those client programs had an option to specify scp. Is there any way that the virtual users can log in to my machine as a normal user would(chrooted though).

    Since yesterday, as soon as anyone logs in, the connection gets, disconnected. It just says connection closed when you do ssh from a unix computer, as soon as it logs in.

    I searched a lot for similar problems, but most of the issues are either solved by deleting the ips from the block lists by fail2ban or the forums are dead without any solutions. I checked on mine but there was none of them blocked in the iptables.

    So i thought, i might have missed something when setting up the server, and thought of starting once again. Thus, formatted the partitions, installed fresh opensuse 11.3 and did a zypper update and reboot. This time set up a perfect server with the
    script for automatically setting up perfect server

    the problem remains. Cannot log into the system using sftp, while scp and ssh gets disconnected as soon as i log in. I tried to log in from my internal network and still the same result.

    I am trying to learn so many things here so i would really like to know "why is it happening" rather than just solving the problem only. I hope this thread will help a lot of newbies like me to start with. Please guide me :)
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess you used chrooted users. Chrooted users do not have sftp enabled as the binaries for ftps are not in the jail, you can use scp instead.

    If you want to give you users a secured way to upload files, you should use ftps (FTP with TLS) which is handled by the FTP daemon and not the SSH daemon.

Share This Page