Perfect Install - Ubuntu 6.06 Dapper Questions

Discussion in 'HOWTO-Related Questions' started by Anim, Jun 5, 2006.

Thread Status:
Not open for further replies.
  1. Bozoman

    Bozoman New Member

    having the same issue also. tried to move on but I'm now having the issue with postfix-tls has no installation candidate and postfix-tls is a virtual package...bla bla bla.

    kind stuck i think
  2. falko

    falko Super Moderator Howtoforge Staff

  3. falko

    falko Super Moderator Howtoforge Staff

    I don't know why it doesn't work for you, but you can use phpMyAdmin to set a password for the server1 row. Restart MySQL afterwards.
  4. babiesmakinbabies

    babiesmakinbabies New Member

    I think I'm dense but I just have a few questions... First, I am using Dapper, but I'm using the xubuntu release, just in case I want to use the UI.

    1. On page 4 when directed to enter this code:

    quotacheck -avugm
    I got this message:

    "quotacheck: WARNING - Quotafile //quota.user was probably truncated. Can't save quota settings...
    quotacheck: WARNING - Quotafile // was probably truncated. Can't save quota settings..."

    But then it proceeded to check and everything was okay. Does the above message matter?

    2. On page 4 when directed to enter this code:

    netstat -tap
    I get almost the same output as the example, but the "PID" (which I assume stands for program ID) never matches the number in your example. Does this matter?

    3. Also on page 4, when directed to enter this code:
    mysqladmin -u root password yourrootsqlpassword
    mysqladmin -h -u root password yourrootsqlpassword
    I'm assuming that I should change the words "password" with my root password and "yoursqlpassword" with the password I want to set for mysql account.


    mysqladmin -u root donkeykong supermario
    mysqladmin -h -u root donkeykong supermario
    Is this correct? I've gotten stuck here 2 times prior. I have started over from scratch 3 times... HELP!

    By the way, thanks for the excellent walk through. I really appreciate it.

    It might be helpful to the extreme noob (like myself) if you also had the vi stuff in the step by step too. that way people know how to edit the files using vi.

    Last edited: Jun 28, 2006
  5. falko

    falko Super Moderator Howtoforge Staff

    That's normal. It always happens when you set up quota.

    No, the PIDs don't matter.

    No, don't replace password, only yourrootsqlpassword.

    Have a look here: :)
  6. babiesmakinbabies

    babiesmakinbabies New Member

    thanks for all your help! I learned a lot!

    now, I on to ispconfig. however, I accidentally encrypted the key (step 7).
  7. falko

    falko Super Moderator Howtoforge Staff

  8. babiesmakinbabies

    babiesmakinbabies New Member

    wow! you guys are amazing!
  9. Slicer

    Slicer Member

    No database entries

    Hi guys.. forgive me if this has been covered and I have not found it.. I am a bit of a newb and I am lost a bit. :confused:

    I was under the understanding that there would be entries in the MYSql database for mail users that were added.. Is this something that I am misunderstanding? I am using ISPConfig to add the users.

    I used this how to along with one located here..

    Thanks in advance..
    Last edited: Jul 7, 2006
  10. lieumorrison

    lieumorrison New Member

    After several retries and new installations using a couple different boxes (all IBM 300GLs though), I still have the exact same problem as tomas112.

    The first couple of tries was with Xubuntu 6.06 installation. The last few have been with Ubuntu Server 6.06. These last few installations I am using the su at root. I followed the directions and counter suggestions from the related forums. The only thing I have done different than what was instructed, is I do have /var in its own partition, but I followed the Breezy instructions to fix that. I am very new to linux, so there could be a user error involved.

    Is there a sub-command that makes pauses when a lot of info is displayed, esp when using ls? I'm just not seeing the option when I use man ls. Also when using
    SELECT * FROM user;
    while in Mysql, it displays in a way that the format is all screwy. I really have no way retyping or copying/pasting that.

    Could you (or anyone) elaborate the process of the aforementioned workaround involving phpMyAdmin. (BTW, I don't know what phpMyAdmin is.)

    As a side note to other readers of the forum, I found that using special characters in passwords (esp '#') will cause wonky unexpected problems, especially with stuff dealing with the RSA keys.
  11. lieumorrison

    lieumorrison New Member


    Since I have quite a few boxes to work with, I moved on to another machine and did another installation this time using Xubuntu 6.06. This install was the first time I didn't run into the problem that I had with all the previous installs. I don't know why it worked and the only thing I did different was install BOINC first. (Berkeley Open Infrastructure for Network Computing - ) The install went well until I did ISPConfig. I've posted that issue under a diffent forum topic:

    I do realize that you can copy and paste if you are using a terminal window (when a graphical interface is installed) or while using ssh from another machine. But I was working directly from the server install because I couldn't ssh anymore because of change in keys because of the reinstalls:
    Someone could be eavesdropping on you right now (man-in-the-middle attack)!
    It is also possible that the RSA host key has just been changed.
    The fingerprint for the RSA key sent by the remote host is
    Please contact your system administrator.
    Add correct host key in /root/.ssh/known_hosts to get rid of this message.
    Offending key in /root/.ssh/known_hosts:2
    RSA host key for has changed and you have requested strict checking.
    Host key verification failed.
    So what would I need to do fix that? I wasn't able to figure out how to correct the host key, as mentioned in the warning message.

    I now realize that phpMYAdmin is a module for ISPConfig, although I have yet to get that far in the installation to see if I can fix the above post's error.
  12. falko

    falko Super Moderator Howtoforge Staff

  13. falko

    falko Super Moderator Howtoforge Staff

    If you don't have ISPConfig installed, simply run
    apt-get install phpmyadmin
    and direct your browser to
  14. Slicer

    Slicer Member

    Thanks Falko for the response.

    I figured out where everything was going after a bit more looking around.

    You say that this is not compatible. Does that mean that some of the stuff such as Amavis will not work. I understand the database part of it now, I just want to make sure everything else will work fine..

  15. falko

    falko Super Moderator Howtoforge Staff

    Your current setup uses virtual users from a database, but ISPConfig uses system users. These are totally different concepts.
  16. LeoLinux

    LeoLinux New Member


    ^^but what if I have a installed ISPconf? Is there any How to to get it work together with ISPconf - using the same users etc... ?


  17. falko

    falko Super Moderator Howtoforge Staff

    Then you can install the phpMyAdmin .pkg package from here: under Management -> Update Manager . You can then find a link to phpMyAdmin under "Tools".
  18. Schmickers

    Schmickers New Member

    Hi all,

    I am new to linux and I am in the process of getting a mail server up and running using this howto.

    My problem is, I am unfamiliar with Courier, and I'm not sure where to start with getting it going. I have gone over the installation guide for Courier at the homepage, but as I downloaded courier and installed it as a package, rather than compiling it from source, I'm not even sure where to jump in with that installation guide! As well, some of the paths it refers to, such as /usr/lib/courier/sbin/courier start, seem not to exist on this setup.

    I guess my question is, where does the "perfect ubuntu server" howto leave you in regards to Courier? How do I begin using it? I am using fetchmail to retrieve messages from my isp's server, and I believe it is working correctly, because when I log into my shell I am now getting the "new mail" message in the login messages. I have used the maildirmake command to create maildirs in the user directories. I am using ISPConfig and have selected the Use Maildirs option under management. However, when I try and log into the server from a mail client with user and password, my connection is denied. I am beginning to wonder if the courier servers are even running, or maybe the howto leaves them in a non-running state for later configuration - I just don't know.

    As you may have guessed, I am a rank linux newbie. Is there anyone out there with any experience in getting a courier/postfix server up and running who can offer some advice? Where do I go from here as far as adding users and being able to login to the mail server?

  19. till

    till Super Moderator Staff Member ISPConfig Developer

    If you followed the perfect setup howto, courier is completely configured. There is no additional configuartion nescessary.

    Dont use Maildirmake if you have ISPConfig installed! ISPConfig does all the mail configuration and creation of the maildirs for you!

    Post the output of:

    netstat -tap
    Just add email users in ISPConfig, the rset is configuread automatically if you installed your server according to the perfect setup.
  20. Schmickers

    Schmickers New Member

    Hey, thanks for the prompt reply, the support here is fantastic. Obviously I need to read the manuals for ISPConfig a bit more closely, as I did not realise that it handled mail administration as well. That's awesome.

    Your guide was great and really well-written. I would like to ask about something peculiar to my setup, however. I do not have a fully-qualified domain name for my server, as I have a dynamic IP address, and I am not ready to set myself up with a dynamic domain name server, once more because I am not entirely sure of the quality of my broadband connection! *grin* The mail and web server is currently intended for use within my LAN, with the possiblity of later joining a DDNS service and maybe going out into the big wide world. I am wondering, then, how your setup should be altered in view of this. Where you use the example string server1, I have entered my machine name (for example, mymailserver). what should I use where you have used the example Should I simply insert the machine name again, without any further domains? Or should I make something up, like just appending to the end of it (for example, And if I do that, how will it affect the working of my server?

    I DO have a domain name registered - If I add this to my setup where you have used the text (so, to continue my example, will it simplify things when I do eventually get a DDNS?

    If these questions are outside of the scope of these forums, then UI'd be happy to be pointed to online sources to research further.

    Once more, thank you for your time.
Thread Status:
Not open for further replies.

Share This Page