Perfect Install - Ubuntu 6.06 Dapper Questions

Discussion in 'HOWTO-Related Questions' started by Anim, Jun 5, 2006.

Thread Status:
Not open for further replies.
  1. Gino

    Gino New Member

    Would be better find your suggested iso file and start from scratch again?

    Hi Falko

    I am old guy and a complete newbie on Linux (two days old) who decided to have a go on Draper due his stability, community support and affordability. Btw, thanks a lot for you help:) .

    1. The link posted by you on the "Perfect Setup..." is not valid for download on". Where can I get this file and attempt to follow your master class on Linux? Should I start again using this file used on your Perfect Setup? From where can I get it?

    2. As I could not grab the suggested file I've downloaded and installed ubuntu-6.06.1-alternate-i386.iso on my server. After two days sweating I manage to install Draper and Webmin following "LAMP Installation On Ubuntu 6.06 For Linux Noobs". But Webmin shows on Conf (after click on Start Apache bottom) "Failed to start apache:
    "Apache does not appear to be running:
    * Starting apache 2.0 web server......done"

    Where I find information to sort out this problem?

    What I should do Falko? Would be better find your suggested iso file and start from scratch again? Or can I use your Perfect guide from now even knowing that software’s were installed through ubuntu-desktop (apache, ssh...)? Should I start my attempt from page 3?

    Have you any idea when the The Perfect LAMP Setup - Ubuntu 6.06 LTS Server (Dapper Drake) will be released?

  2. falko

    falko Super Moderator Howtoforge Staff

    It's mentioned in the tutorial:

    What's the output of
    netstat -tap
    ? What's in Apache's error log (in /var/log/apache2, I think)?

    That's exactly what "The Perfect Setup - Ubuntu 6.06 LTS Server (Dapper Drake)" is about...
  3. Schmickers

    Schmickers New Member

    Actually, the link you provided, regarding amavisd and clamav, is not quite what I was after.

    I want to instigate server-side filtering rules that each mail user can specify, to sort incoming mail (such as mailing lists) into imap folders. As far as I can tell, the perfect setup does not allow for this. How would you suggest I go about this? I know that Courier has Maildrop as a mail transport agent, but I'm not sure how to get that working, or even if it would work in this setup.
  4. falko

    falko Super Moderator Howtoforge Staff

    You could use procmail recipes to do this.
  5. Schmickers

    Schmickers New Member

    Okay. Now, I'm aware that ISPConfig uses procmail recipes to redirect incoming mail to user maildirs, but does it support user-configurable procmail recipes? I suspect it doesn't, as I haven't stumbled across this feature.

    How well woukld ISPConfig combine with another web-based management systems, like Webmin? A quick and dirty seach indicates that Webmin has user-management functions as well, but would these conflict with ISPConfig's combined web- and user-management features? Or would installing Webmin simply work?

    If not, are there any suggestions for other web-based management systems (either standalone, or combined with a webmail application) that might be of use in configuring server-side procmail recipes on a user-by-user basis?
  6. falko

    falko Super Moderator Howtoforge Staff

    You'd have to edit the procmail recipes on the command line and be aware that your changes are lost whenever you update that user (unless you write your procmail changes also to the procmail template files in /root/ispconfig/isp/conf).

    Yes, there would be a conflict. You can use Webmin for all tasks not covered by ISPConfig (and vice versa), but don't use Webmin for tasks that are covered by ISPConfig, or you'll mess up your system.
  7. Schmickers

    Schmickers New Member

    Hmmm ... okay. What exactly causes the "update" of a user? Once I create a web and a user on that web, when can I expect them to be "updated" and my .procmailrc to be removed?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    When you change any setting of that user in ISPConfig.
  9. Schmickers

    Schmickers New Member

    Okay...after some testing, I am faced with a problem.

    One of the main things I need this server to be able to do is sync imap with Palm Versamail. Unfortunately, Courier IMAP is strict with it's namespaces, and all mail subfolders must be located below Inbox. This is incompatible with Versamail, which can only synchronise folders below the root namespace.

    As a result, I need to change to Dovecot, which is does not strictly implement this feature and will allow the creation of directories at the root level of the Maildir.

    How would I go about changing to Dovecot? If I use apt-get to remove Courier, and then apt-get to install the relevant Dovecot packages, can I expect Dovecot to just slide into place, as they both use Maildirs? Or is there more configuration involved to make Dovecot function with ISPConfig?
  10. till

    till Super Moderator Staff Member ISPConfig Developer


  11. nuzzy

    nuzzy New Member


    I keep getting the following:

    root@mail:/home/nuzzy# mysqladmin -h mail -u root password *********
    mysqladmin: connect to server at 'mail' failed
    error: 'Host '' is not allowed to connect to this MySQL server'
    root@mail:/home/nuzzy# mysqladmin -h -u root password *********
    mysqladmin: connect to server at '' failed
    error: 'Host '' is not allowed to connect to this MySQL server'
    Not sure why I'm getting this. As you can see I've tried both the hostname and FQDN.
  12. falko

    falko Super Moderator Howtoforge Staff

  13. tim.n9puz

    tim.n9puz New Member

    BIND and Routers, Still Fuzzy.

    "My system's IP address in this tutorial is, and my hostname is"

    If my installation is similar to the above and I end up with something like how does traffic from the outside world get passed to and from the computer that's behind the router? For example if barney has my mail server and someone outside my local network has as the SMTP address in their client does the BIND configuration take care of getting it to the right machine on my local network?

    Also, are there any gotchas with trying to do this using a dynamic DNS address from or similar?

    Great tutorials by the way. I know they get large as it is but it would be even better if there were a little more background on what we were doing as we typed in the commands.

  14. jjw

    jjw New Member

    I assumed I was wrong when I was getting

    instead of

    in the setup. So I tried the install three times and when the output was the same, I assumed that I was wrong, so I stopped trying to install Dapper Drake.

    And then I read this thread...
  15. jjw

    jjw New Member

    The outside world is pointed by a DNS record to whatever IP you set up in that record. If you have an IP (from your ISP) of, and your record is different, then the outside world is pointed to the wrong IP. The IP in the tutorial is a LOCAL IP, one that is non-routable to the outside world. Assuming you have a router (which is amongst other things a hardware firewall), you can open ports on it (depending on it's flexibility) to point to various LOCAL IPs on your LAN. For instance, you have a mail server, you have a HTTP server, and you have a MySQL server on three different machines. You open port 80 on the router to point to your LOCAL http server, open ports 25, 110, 143, 993, & 995 (depending on services offered) to point to your mail server, and 3306 to point to your MySQL server. This way, if your records all point to your single IP, your route packets/connections to the correct server depending on the incoming port.

    The only gotcha is if you don't have current information (the right IP address) entered in your DNS registration.

    I've had dynamic IP addresses that remained the same for 6 months or more, because I always had the machine on and becuase the network wasn't reset by the techs/sysadmins.

    Take this info for what it's worth, and a grain of salt, as I am a noob to this forum and Falko's 'How Tos'. Hope that helped.
  16. mbunal

    mbunal New Member

    try that:

    echo host.domain.tld > /etc/hostname

    then reboot

    check it:

    hostname -f

    this is work for me.
  17. usuee

    usuee New Member

    Same issue and no reply

    I am having the same issue...

    You ask for the contents of the /etc/postfix/, well here is mine...

    root@server1:/etc/postfix/ssl# cat /etc/postfix/
    # See /usr/share/postfix/ for a commented, more complete version

    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname =
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination =,, , localhost
    relayhost =
    mynetworks =
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    smtpd_sasl_auth_clients = yes
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destinations
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    I swear I have read it over and over looking for my typo but I can't find it. HELP.

    BTW, this is a wonderful tutorial. I only wish you had more comments about why you do some of the steps. I am pretty much a noob, like many others.
  18. falko

    falko Super Moderator Howtoforge Staff

    What's the output of
    telnet localhost 25?
    What's in /etc/mailname, /etc/hosts, and /etc/resolv.conf?
  19. usuee

    usuee New Member

    The output requested

    Here you go...

    root@server1:~# telnet localhost 25
    Connected to localhost.localdomain.
    Escape character is '^]'.
    telnet> quit
    Connection closed.
    root@server1:~# cat /etc/mailname
    root@server1:~# cat /etc/hosts localhost.localdomain localhost server1

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    root@server1:~# cat /etc/resolv.conf
    search Domain

    I have to escape out of telnet because it doesn't do anything after I log in.
  20. falko

    falko Super Moderator Howtoforge Staff

    Is a resolving name server?

    What's the output of
    You can try to run
    postconf -e 'smtp_host_lookup=native'
    /etc/init.d/postfix restart
Thread Status:
Not open for further replies.

Share This Page