Perfect Setup SuSE 10.1 -- Now what?

Discussion in 'HOWTO-Related Questions' started by Crog, Jun 13, 2006.

  1. Crog

    Crog New Member

    Just to begin, I'm pretty much a newbie when it comes to Linux in general, so please don't be too hard on me :D . I followed the guide, everything seemed to have installed flawlessly and is running, as far as I can tell.

    I can http://<my ip address>:81 (if I'm accessing remotely) or http://<static router assigned ip>:81 (if I'm in the network), it then takes me to the ISPConfig login screen, I can log in just fine.

    The real question is: how can I put up some webpages, and how would I connect to them?

    The directory I specified was /home/www (directory where ISPConfig will create websites)

    From what I understand if I should type in http://<my ip address>:80, port 80 is the standard HTTP port (which should be equivalent to just typing http://<my ip address> ) I'll need to put in some form of index file, such as index.html or index.php, that it will resort to by default.

    So how would I go about doing this? Where would I start in building a webpage directory that anybody can just type in http://<my ip address> and it'll take them to a website I made?
    Last edited: Jun 13, 2006
  2. warpengi

    warpengi New Member

    Usually you put pages you want available on the web in /var/www or /var/www/html. One of those is likely the default folder where you put your index.htm file. You can also put folders there for your web pages.


    /var/www/html/myfolder would be accessed from http://myipaddress/myfolder or http://mydomainname/myfolder. Then the index.htm in that folder would be displayed.

    I have not used /home/www for web pages so can't help you there.
  3. Crog

    Crog New Member

    Hrmm...that doesn't seem to work either.

    First off, I'm reading about Apache and to test it, they say to type in http://<ip address> (if you're connecting remotely) and a Congratulations splash screen should show...however, I see this only:

    Access forbidden!
    You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

    If you think this is a server error, please contact the webmaster.

    Error 403
    <my ip>
    Mon Jun 12 20:09:56 2006
    Apache/2.2.0 (Linux/SUSE)


    Any ideas?
  4. warpengi

    warpengi New Member

    Keep reading your Apache documentation and the howto that got you this far. Somewhere along the line you have not configured something right.

    Sorry that I can't be more help but I'm not familiar with the howto that you followed and so not sure where your problem is exactly.
  5. Crog

    Crog New Member

    Well, I followed the perfect setup guide, was hoping that it was all that was necessary... I wouldn't even know where to start looking in most of the configuration files for any program :p

    Would that 403 error that I posted earlier narrow down where the problem lies?
  6. warpengi

    warpengi New Member

    Look in /etc/apache2 for the config files and read through those. The there may be a README file there as well.
  7. falko

    falko Super Moderator Howtoforge Staff

    That's normal for the standard web site on SuSE, don't ask why...:confused:

    The IP address will not work as ISPConfig uses name based vhosts. All you will see if you use the IP address is the shared IP page.

    To create a web site in ISPConfig you first have to creaste a customer, and then you create a web site for this customer in ISPConfig. That's all, and then you can access the web site in your browser using the web site's domain (provided that the DNS records of the domain point to the correct server).
  8. Crog

    Crog New Member

    Sweet, got it working, well almost.

    It says the following:

    How would I go about fixing this?
    Last edited: Jun 13, 2006
  9. Crog

    Crog New Member

    Awesome, I got it working...did a search on the shared ip thing, and it turns out that I needed my DNS pointing to my external ip address
  10. Crog

    Crog New Member


    When I said I got it working (previous post), I got to the default index.html page, where it says you can make changes to your webpages in the web directory....

    I checked to see if I can connect via Web-FTP, it was successful, I can see all the folders, the last listed folder was web. I expand that directory, and inside was the index.html and an error folder. Then I logged out so I can then log in with a more flexible FTP client.

    I successfully log in with my FTP client and download the index.html file in the web directory (to keep as a copy before I make changes). I then delete that index.html file in the web directory, upload my index.php file:

    Then I tried my website again, and it took me to the same default index.html page.

    So I noticed a user folder, and expanded it...another folder was listed with my username, and under that username was another web folder which had another index.html file (so I naturally thought that the web directory stated on the default index.html page was the one contained in the directory: user/<username>/web), deleted that index.html file, uploaded my index.php file.

    I tried my website again, and it now took me to the Access Fobidden! Error 403 page that I posted earlier.

    Hopefully to get things working the way they used to, I uploaded the copy of the original default index.html file back into /web and /user/<username>/web directories. But unfortunately, whenever I try to go to my website, I still get the Access Forbidden Error 403 page...

    I got frustrated and deleted absolutely everything I configured in ISPConfig (reseller, client, etc) and about to give it another try.

    Any ideas on what my problem was?

    EDIT: After trying to do a fresh start with ISPConfig (deleting all the information and resellers, clients, sites, etc), I tried deleting the Server Settings (Management > Server > Settings) and get the following message:

    After I make changes to any of the fields, hit save, and then return to Settings, my old Server name, host name, domain, etc. are all still there.

    I even did a reinstall of ISPConfig and the old values that I inputed before were still there...and still cannot be changed.

    How do I revert ALL the values stored in ISPConfig back to how they were when it was installed for the very first time?!?
    Last edited: Jun 14, 2006
  11. falko

    falko Super Moderator Howtoforge Staff

    Please uninstall and then reinstall ISPConfig again.

    I think you somehow mixed up the site admin and normal users of the site and then somehow deleted and uploaded to the wrong directories.
  12. Crog

    Crog New Member

    I ended up doing another reinstall of SuSE 10.1 and decided not to install ISPConfig ... and I am loving that decision :p Seemed a bit confusing and the manual didn't really help things click.

    And the install of ISPConfig takes a very long time (especially on the old 233 MHz :eek: , what can I say, it's the only other computer I have laying around).

    I'll probably give it another shot when I get more experienced and comfortable with Linux and all the configurations in general.
  13. Skylinux

    Skylinux New Member

    I'm running OpenSuse 10.1 and have the same problem, Access forbidden.
    I'm quite sure that I am the problem - who else ;).
    The Perfect Setup - SuSE 10.1 (32-bit) manual states at the bottom of the last page to choose "Expert" installation mode and change Web-Root to /srv/www
    I ignored the warning on purpose since I decided to mount my large raid at /home. So I went ahead with the install since I was going to change the apache config later. Little did I know how large ISPConfig really is......
    After a little playing I have uninstalled ISPConfig and I'm now reloading it with probler settings, I think, after uninstalling and reinstalling everything related to apache2 and php.

    Once my 1GHz VIA CPU is done compiling I will know more. I'll keep this threat posted.

    BTW, is there a way to keep the compiled files when I uninstall ISPConfig?

  14. falko

    falko Super Moderator Howtoforge Staff

    You can backup the /root/ispconfig directory, but it doesn't make much sense because the applications get compiled again when you install ISPconfig.

Share This Page