Perfect Setup Suse9.3

Discussion in 'HOWTO-Related Questions' started by kingkunt, Dec 3, 2005.

  1. kingkunt

    kingkunt New Member

    I folowed the tutorial and get to the installing apt part and i get ERRORS.

    auto:~ # apt-get install findutils ncftp readline libgcc glibc-devel findutils-locate gcc flex lynx compat-readline4 db-devel
    Reading Package Lists... Done
    Building Dependency Tree... Done
    findutils is already the newest version.
    E: Couldn't find package ncftp
    If i continue to the next part i get:
    E: Couldn't find package quota
    auto:~ # 
    My sources.list file has both the and the mathematik mirror uncommented,but after i run apt-get update all i get is package not found errors??

    What am i missing?
  2. falko

    falko Super Moderator Howtoforge Staff

    What's in /etc/apt/sources.list?

    Instead of using apt, you can also try to install these packages with yast.
  3. kingkunt

    kingkunt New Member

    thanks for the quick reply.

    my sources.list contains this

    # A very basic sources.list file.
    # Remove "base" in case you are behind a slow connection.
    # Fastest repository comes first, with netselect it is possible to determine
    # the fastest repository easily.
    # Visit the server to determine which apt components are provided.
    rpm SuSE/9.3-i386 update security rpmkeys
    rpm SuSE/9.3-i386 update security rpmkeys
    # The list with all available components can be found at:
    # Some components provide experimental software, select wisely!
    # Consult the link above if you want to include uri's for src rpms
  4. falko

    falko Super Moderator Howtoforge Staff

    It should contain this line:

    rpm SuSE/9.3-i386 [COLOR="Red"]base[/COLOR] update security
    (as described on ).

    Don't forget to run
    apt-get update
    after you've changed /etc/apt/sources.list.
  5. kingkunt

    kingkunt New Member

    my problem was the file wasnt saving properly.

    I ran into this problem with proftp when trying to start it

    auto:/tmp # /etc/init.d/proftpd start
    /etc/init.d/proftpd: line 1: {rtf1ansiansicpg1252deff0deflang1033{fonttbl{f0fromanfcharset0: command not found
    /etc/init.d/proftpd: line 1: }{f1fswissfcharset0: command not found
    : command not found: line 1: }}
    /etc/init.d/proftpd: line 2: {*generator: command not found
    /etc/init.d/proftpd: line 2: }viewkind4uc1pardsb100sa100f0fs24: command not found
    : command not found: line 3: pardf1fs20par
    : command not found: line 4: }
    I compiled it ok and copied the proftp text to a file called proftp and saved it in init.d but when i issue the start command i get all these errors?
    Do i need to save the proftp file with a certain extension.
    thanks for all the help :rolleyes:
  6. falko

    falko Super Moderator Howtoforge Staff

    You mean proftpd, I guess?

    Did you save the file with Unix linebreaks? When you created the file on a Windows system, it is likely to have Windows linebreaks.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    For me the error message looks like you have written the file with word or wordpad and saved it as rtf file. Better use an linux editor to create the file or use an windows editor like edit or notepad and convert the linebreaks to linux linebreaks when you transfer the file with scp or ftp to your linux server.

Share This Page