Permission problems

Discussion in 'Installation/Configuration' started by webhunter, Jun 8, 2016.

  1. webhunter

    webhunter Member

    suddenly I ran in to permission problems.
    Can someone help me out with the right permissions in /var/lib and /var/spool ?
    Dunno how that coul happen but now all files are owned by vmail..

    Thank you!
  2. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    That will depend on what OS distribution/version you're running, and what packages you have installed. You might be able to use the package manager data to find the correct owner/group/permissions and reset to those (eg. try "how to reset permissions from rpm package settings" or "how to reset permissions from dpkg package settings" in google), then re-run the ispconfig to apply ispconfig changes.
  3. webhunter

    webhunter Member

    It seems that I
    - can't install ISPConfig again, because it complains about an installed version
    - can't reset the user/group/permissions into a "default" state (Therefore you need an identical system and to check all permissions manually)
    But, thank you!
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    How shall we be able to help you when you dont even post the OS that you use? And ispconfig is not related to permissions in /var/lib or /var/spool as ispconfig does not store files there.

    So the first step ist:

    Which exact OS do you use?
    And why do you want to reinstall ispconfig? It is not using these folders.
  5. webhunter

    webhunter Member

    @till : No, no,... you misunderstood. It was not a problem of ISPConfig. I changed - somehow - the permissions and user/groups of some system related files to vmail. So, none of the installed services worked correctly. But you can forget about this thread. A new install was much easier and faster than setting the correct permissions... ;)

Share This Page