Permissions issues in web space

Discussion in 'Installation/Configuration' started by Antonio_Boqueron, Oct 13, 2016.

  1. Antonio_Boqueron

    Antonio_Boqueron New Member

    Need urgent help, please.
    I have debian (Jessie) and ispconfig 3, everything works fine, but when you move a website from another hosting to ispconfig in the space created by the ispconfig (when a new website is created), appear trouble viewing this page, I can only see the main page and the rest have error (error page doesn´t found). I'm sure you are permissions problems, just let me know how to fix the permissions that are set by creating a espace for a new Web from ispcofig (ispconfig create a new web user for each web space created).
    I realize the transfer of the page as always without problems on other hosting, and I always moved it my webs, compressing the content and after uploading it directly by ftp and unzipping directly in that space. Is there a special way to do it in the ispconfig? I've never had these problems with other hostings.
    All other functions are work fine.. in ispconfig data base, mail, domain all .....
    Thank you very much.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Page not found errors are no permission errors, permission errors are 403 or 500 errors and not 404. Page not found mena that you either missed to migrate a .htaccess file or that you did not upload all files. The most ikely reason is that you did not upload the .htaccess file of the site.

    Regarding file permissions (which are not your current problem): There are no permissions to be set manually after ispconfig created a site, all is setup correct automatically. When you upload a site with an FTP user or SSH user of the website, then all fiels are owned by the right user automatically. In case you uploaded and unzipped the files as root user, then the owners of the files must be wrong (not ispconfig related btw) as the files have the permission of your old hosting. In this case you have to chown the whole content of the web folder to the web]ID] user and client[ID] group of the website.

    Regarding write prmissions for website scripts, php mode should be php-fcgi or php-fpm and the suexec checkbox must be enabled.
  3. Antonio_Boqueron

    Antonio_Boqueron New Member

    Thank you very much for your quick response.
    I've finally solved thanks to you, it is not a permissions problem is a problem of property as you answered. Ispconfig when you create a web site also creates a user like you said and all I make after in that web space created must have the property of that web user (not enough to have root permissions), therefore, change all the property of that directory:
    chown -R "web user" "folder" (from upper folder for example), and everything worked perfectly.

    Thank you very much for your professional help.
  4. Antonio_Boqueron

    Antonio_Boqueron New Member

    Hello again...
    Excuse me.......... sorry I just been that is not the correct forum.... only one question more...

    It has been solved with a web in wordpress, but on another website in wordpress not worth this solution, now if an error of fact permits, and 500 error when I give display the error is as follows:

    Warning: is_dir(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/var/www/clients/client0/web6/web:/var/www/clients/client0/web6/private:/var/www/clients/client0/web6/tmp:/var/www/ in /var/www/clients/client0/web6/web/wp-content/plugins/SebMap/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 93

    Fatal error: Uncaught exception 'Twig_Error_Loader' with message 'The "/" directory does not exist.' in /var/www/clients/client0/web6/web/wp-content/plugins/SebMap/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:94 Stack trace: #0 /var/www/clients/client0/web6/web/wp-content/plugins/SebMap/vendor/twig/twig/lib/Twig/Loader/Filesystem.php(76): Twig_Loader_Filesystem->addPath('/', '__main__') #1 /var/www/clients/client0/web6/web/wp-content/plugins/SebMap/vendor/twig/twig/lib/Twig/Loader/Filesystem.php(34): Twig_Loader_Filesystem->setPaths('/') #2 /var/www/clients/client0/web6/web/wp-content/plugins/SebMap/vendor/getherbert/framework/Herbert/Framework/Providers/TwigServiceProvider.php(23): Twig_Loader_Filesystem->__construct('/') #3 /var/www/clients/client0/web6/web/wp-content/plugins/SebMap/vendor/illuminate/container/Container.php(731): Herbert\Framework\Providers\TwigServiceProvider->Herbert\Framework\Providers\{closure}(Object(Herbert\Framework\Application), Array) #4 /var/www/clients/client0/web6/web/wp-content/plugins/S in /var/www/clients/client0/web6/web/wp-content/plugins/SebMap/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 94

    How is posible that the before solution doesn´t solve this problem? but nevertheless in ther other website (wordpress) all ok perfetly, I move this web by the same way, exactly the same, chage all permissions "web user" and "group" all the folder.

    Thanks a lot.!!!!
    Last edited: Oct 16, 2016
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Your software tries to load a file / (root directory of the server) as the path / is outside the website folder /var/www/clients/client0/web6/web/, php rejected it.
  6. Antonio_Boqueron

    Antonio_Boqueron New Member

    I thought that by moving the new web to the new site, the information "/" the old hosting, exchange to new / base of the new hosting, ie.
    "/ Var / www / clients / client0 / web6 / web /" corresponds to the new "/"
    And it should work ....?

    Because there is no absolute way to say it, isn't it?

    The same would have happened in the old hosting, because not have access to "/" (outside the folder of the Web) and yet it works.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You mix up the URL / with the folder /. The URL / is mapped to /var/www/clients/client0/web6/web/ automatically but the folder / is something different and the error message is about the folder / and not the URL /.
  8. Antonio_Boqueron

    Antonio_Boqueron New Member

    you refer to a folder called "/" I do not understand.....
    I think is the path root of the new hosting base....
    If you refer to the folder "/" is to folder "/var/www/clients/client0/web6/web" isn´t it ?
    Last edited: Oct 17, 2016
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    You mix UP a URL with a Linux system folder. The PHP error message is about a Linux System folder and not a URL. The Linux System folder / is the root of the whole server file system, it is not the same then the URL / of a website and off course a single website ahs not the permission to access the / Linux folder which contains the whole OS and all other websites as well. If you want to allow your website to access the Linux system root (which makes no sense, but you can do that of course) instead of correcting your software to not try to gain access to the system root, then enter the word "none" in the open_basedir field on the options tab of the website.
  10. Antonio_Boqueron

    Antonio_Boqueron New Member

    I m sorry, I khow isn´t the seccion for ispconfig problems I only want to closed.... The next time to be in the correct seccion.

    First of all... thanks for your patience ...... but I'm going crazy with ispconfig permits, almost ispconfig leave.

    The last, I do not work another site, to make the transfer from another hosting (ispconfig permissions problems):

    In this web, if I change user permissions and group own space web (/ var / www / clients / cliente0 / web12 / web), It works very badly (you can see the page as free cms), but, if I put root and root group all it works.

    But for example in the location:

    There are images that look and others are not (they are in the same area of the website and have exactly the same user and group permissions and the same).
    It's amazing how can this be if the images are exactly the same ones together with other (you should see all or none, no?), is this normal?

    In the end I think it's no permissions problem, another problem..... php.... (I tried all modes...)

    I'm desperate!!!!
    Last edited: Oct 23, 2016

Share This Page