php-fpm not picked up in client template

Discussion in 'Installation/Configuration' started by Richard Foley, Aug 12, 2019.

  1. Richard Foley

    Richard Foley Member

    hi all,

    I'm trying to set up some client templates here to use PHP-FPM by default. I don't seem to have this available under Clients->Limit-Templates->Template. All the options I see are (and switched off/unchecked):
    I have gone to System->Server-Config->Server->Web->PHP-Settings and selected PHP-FPM as the default PHP handler. However, under templates I still don't see the option available (under client->templates). Any ideas what I'm doing wrong, anyone?

    Using debian 9 (stretch) here.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no such option in the templates yet.
  3. Richard Foley

    Richard Foley Member

    hi Till,
    I think I've figured it out. Interface->Main-Config->Sites and there you can select the various PHP/CGI options to apply to clients (I think). However, what was misleading was the
    label which seemed to imply this was only for Apache (and I'm using nginx). So I ignored the label and checked the PHP-FPM box. The important thing is that it works...

Share This Page