php system() and exec() not returning anything

Discussion in 'General' started by sjau, Jun 2, 2015.

  1. sjau

    sjau Local Meanie Moderator

    Hi there
    Hmmm, I'm just hitting a wall right now. I created a little php script and need to do a whois lookup.
    I thought of using exec() but nothing was returned. Then I tried system() with same result.
    The weird thing is, I don't get any errors or log entries.
    Using current ISPC and site is set - due to nostalgia - to suPHP.

    Any ideas?

    Addon: Interestingly, having a script on the server with just

    $w = exec("whois");
    echo $w;
    runs fine when I log into the server and su myself to the according webXX user and run the script from the cli.
    Last edited: Jun 2, 2015
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    any disabled functions in the php.ini that suphp uses? Did you try a different php mode (e.g. fcgi + suexec)?
  3. sjau

    sjau Local Meanie Moderator

    I tested now fcgi and then it just miraculously worked. I guess it has to do with apache 2.4.10. I worked fine with 2.2 as far as I can remember.

Share This Page