PHP7 on CentOS 7 with ISPConfig I have multiple php versions already but...

Discussion in 'Installation/Configuration' started by MikaelWinther, Dec 27, 2015.

  1. MikaelWinther

    MikaelWinther New Member

    PHP7 on CentOS 7 with ISPConfig I have additional php versions already (5.6.16, 5.5.30 and 5.4.45) and they work flawlessly, but if i try to make a php 7, the httpd service will not start anymore. I have tried several different options in the ./configure part (sample below), so my guess is that something in the httpd configuration breaks when the make and make install commands are run, do you have any experience with this, as i would like to have the ability to test websites with php 7.0.1 asap... :)
    I have read that it is also possible to install php 7 via rpm, but i would not want to replace the php version ISPConfig is running with, just make it available as a website option just like the other php versions.
    Thank you very much for any assistance! - Sincerely Mikael Winther

    ./configure --prefix=/opt/phpfcgi-7.0.1 --with-config-file-path=/opt/phpfcgi-7.0.1/etc --with-pdo-pgsql --with-zlib-dir --with-freetype-dir --enable-mbstring --with-libxml-dir=/usr --enable-soap --enable-calendar --with-curl --with-mcrypt --with-zlib --with-gd --with-pgsql --disable-rpath --enable-inline-optimization --with-bz2 --with-zlib --enable-sockets --enable-sysvsem --enable-sysvshm --enable-pcntl --enable-mbregex --with-mhash --enable-zip --with-pcre-regex --with-pdo-mysql --with-mysqli --with-jpeg-dir=/usr --with-png-dir=/usr --enable-gd-native-ttf --with-openssl --with-fpm-user=apache --with-fpm-group=apache --with-libdir=lib64 --enable-ftp --with-kerberos --with-gettext --with-xsl --with-tidy --with-xmlrpc --enable-intl --enable-opcache --enable-cgi
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The additional PHP versions are not integrated into httpd directly, so even a failed install should not cause httpd to fail.

    Installing php 7 should work on centos 7 as well, I just installed it on Debian yet. You can try to use the debian configure string from this tutorial:

    Don't install a php 7 rpm, it will break your server.
    MikaelWinther likes this.
  3. MikaelWinther

    MikaelWinther New Member

    I tried using the string from the debian tutorial already, configure runs, make runs, and make install runs, however then the httpd service will not restart.
    Did anyone try this on Centos 7? - and got it to work? :)
  4. yum does not even get the prerequisites when trying to install from the debian tutorial mentioned before. I would also appreciate if anyone would show how to install php 7 on centos 7 and add it to ispconfig 3.1.
  5. Thaddeus

    Thaddeus New Member

    There is another way you can do it. If you use the remi repo
    cd /tmp
    rpm -ivh  remi-release-7.rpm
    You can install PHP7.0 in no-conflict mode. This means that your FPM service will be php70-php-fpm, your php.ini will be different, and your cli will be php70

    yum install php70-php-bcmath php70-php-cli php70-php-common php70-php-fpm php70-php-gd php70-php-intl php70-php-json php70-php-mbstring php70-php-mcrypt php70-php-mysqlnd php70-php-opcache php70-php-pdo php70-php-pear php70-php-pecl-uploadprogress php70-php-pecl-zip php70-php-soap php70-php-xml php70-php-xmlrpc -
    Edit /etc/opt/remi/php70/php-fpm.d/www.conf
    listen =
    listen =
    Then you can start it
    systemctl start php70-php-fpm
    systemctl enable php70-php-fpm
    In Ispconfig Additional php versions

    Name: PHP70
    FastCGI tab
    Path to the PHP FCGI binary:
    Path to the php.ini directory:
    PHP FPM tab
    Path to the PHP-FPM init script:
    Path to the php.ini directory:
    Path to the PHP-FPM pool directory:
    Last edited: Jul 11, 2016
  6. Thank you so much!
    I gert this error though with the second line of your code:
    error: open of ius-release.rpm failed: No such file or directory
    warning: remi-release-7.rpm: Header V4 DSA/SHA1 Signature, key ID 00f97f56: NOKEY
    do I have to change directories before wget-ing?
  7. Thaddeus

    Thaddeus New Member

    the command is
    rpm -ivh remi-release-7.rpm
  8. Thanks. Now it's working.
    I suggest you edit your post? :)
    Thanks again!
  9. kyferez

    kyferez Member

Share This Page