phpmyadmin is 404 on port 8080

Discussion in 'Installation/Configuration' started by bmazloum, Feb 11, 2016.

  1. bmazloum

    bmazloum New Member

    Ubuntu 14.04, Apache2, ISPConfig 3.05.4p8
    I have gotten phpmyadmin to work on
    However I cannot access it on, it prompts me with a 404

    This happens when I click on the database icon next to my sites. I've reinstalled ispconfig and phpmyadmin and nothing has changed. The only reason I can access it from is because I personally placed the link there but that doesn't seem to be a secure way to do this, right?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The link that you added is not required and should be removed. You missed to activate phpmyadmin during its installation in the apt dialog, you can redo that by running:

    dpkg-reconfigure phpmyadmin

    Ensure that you enable the apache option before you select next.
  3. bmazloum

    bmazloum New Member

    Hi, thank you for your response. Unfortunately I followed that step and I just did it again to confirm and still no go.
  4. Well-Known Member HowtoForge Supporter

    Are you using apache-mpm-worker with php-fastcgi/fpm only by chance?
    Then you might miss the DirectoryIndex index.php option, is it showing you source-code if you add /index.php at the end of the URI?
  5. bmazloum

    bmazloum New Member

    Don't have apache-mpm-worker installed, disabled mpm_event and am using mpm_prefork if that makes a difference? Yes I only have php-fastcgi/fpm installed.

    Clicking on the database icon I come across the certificate screen again, the link is
    which then takes me to
    Even if I add /index.php I still get the 404.

    I just checked the error log, after the security warning I have.
    [mpm_prefork:notice] [pid 29311] AH00163: Apache/2.4.7 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 PHP  /5.5.9-1ubuntu4.14 mod_python/3.3.1 Python/2.7.6 OpenSSL/1.0.1f configured -- resuming normal operations
    Thanks for any help.
  6. Well-Known Member HowtoForge Supporter

    Using fastcgi / cgi in combination with mpm_prefork is very bad memorywise - if that's a concern since php threads won't share their memory ( opcode cache will be seperate for each thread ) If using php with cgi that way will spawn one process per request leading to poor performance. But that's a complete different topic :)

    phpmyadmin relies on mod_php to work so you might need to adjust the default configuration to work with fastcgi. An easy and quick hack would be to disable the phpmyadmin default configuration and symlink /usr/share/phpmyadmin to /var/www/ispconfig folder. Beware that phpmyadmin might not be allowed to read its configuration files this way and additional work is needed e.g. changing and setup blowfish and stuff like that.

Share This Page