phpmyadmin show blank page when searching database

Discussion in 'Server Operation' started by felan, May 24, 2016.

  1. felan

    felan Member HowtoForge Supporter

    After the last update of phpmyadmin, whenever we wish to search for something in our databases with it, we just get a blank page, when hitting the search tab. Anyone who got the same problem and know how to fix it? I just tried to purge it and reinstall, didn't help...

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the apache error.log for the reason of the issue. Maybe a missing PHP module that is required for the new PHPMyAdmin version.
  3. felan

    felan Member HowtoForge Supporter

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    That'san error in the PHP code of the PHPMyAdmin version. I guess this should be fixed soon with a new PHPMyAdmin update from the maintainers.
  5. felan

    felan Member HowtoForge Supporter

    Thanks :) I'll have to poke to see when a new version will be out.
  6. Aivaras

    Aivaras Member

    I also have a blank phpmyadmin page after the update (master server)...
    AND other servers can't connect to master database when Im trying to upgrade them (to ISPConfig 3.2 upgrade)... But control panel work.

    I have updated mysql root pasword (into the same as it was ) by folowing these steps:
    I have included phpmyadmin:
    Include /etc/phpmyadmin/apache.conf

    None of these action does not help.
    What else could I do, what can you recommend? My PHP Version 5.6, Debian 8.4

    Attached Files:

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that the php-gettext package is installed. There is an issue on the Debian PHPMyAdmin package that misses to install it as a dependency of phpmyadmin automatically.
  8. Aivaras

    Aivaras Member

    Yes, I have checked it..:(
    php-gettext is already the newest version
    Last edited: Feb 27, 2017
  9. Well-Known Member HowtoForge Supporter

    Have you tried to use the database connection details from command line from the other server which can't connect to master yet?
    Check the user table on your master wether the user is allowed to connect from your slave-host. Keep in mind that if you did not turn off host-resolving in your database it may resolve the IP to an hostname and if you don't have the user privileges with the given hostname but with the IP only it won't succeed. Either add the user with the hostname or disable host-lookup in your database server.

    And just to be sure, you may set the password again to the same it should be just to be sure.

Share This Page