please TEST tutorial before pubishing

Discussion in 'HOWTO-Related Questions' started by IzFazt, Sep 1, 2021.

  1. IzFazt

    IzFazt Member HowtoForge Supporter

    palak pandit likes this.
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    That it does not work on your system does not mean it doesn't work on any system. Maybe you made a small mistake somewhere for example. However, if you think something is wrong, you can let us know and we can see if it is indeed.
    palak pandit likes this.
  3. IzFazt

    IzFazt Member HowtoForge Supporter

    The tutorial crashes when executing
    ./ --interactive
    it is missing access rights, users and dependencies visible using the --debug option on second tryout, debian 10 updated upgraded, using standard system utilities plus ssh in Proxmox VM
    Last edited: Sep 1, 2021
    palak pandit likes this.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The tutorial has been tested and it was perfectly fine at the time it was published. So please stop posting such unbacked claims that all tutorials don't work or that we don't test tutorials! If you compare the tutorial with the Modoboa docs, then you notice that it's completely in line with the way Modoboa is installed according to its developers. So if the tutorial would be wrong, then the installation instructions from Modoboa devs must be wrong as well. And you should know that software changes regularly and that it depends on the base system you install it on, so there can be always later changes in software or issues caused by an unclean or limited base system that makes a guide fail for you at a later timepoint while it worked perfectly fine earlier or even works all the time for other users on a different base server.

    To test it again, I just installed it as shown in the guide and the installer does not crash nor are there any permission errors during install. You say that you are using Proxmox, do you use an LXC container? LXC containers are not compatible with some software, so using LXC might be the simple reason for your install errors, especially as using LXC can cause permission errors.

    There is one problem though, which is not related to the tutorial. It's a bug that was introduced in Modoboa recently and which has not been fixed yet. The issue and its solution are described here:

    After applying this bugfix, the symptom is an "Internal Server Error" message to be shown after logging into Modoboa UI, not a permission error during installation, Modoboa is working fine. I've added a note to the guide that there is currently a bug in Modoboa.

    See successful install screenshots:

    2021-09-02 09_56_06-Dashboard.png 2021-09-02 09_56_28-.png
    ahrasis likes this.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Btw. I moved the post to the correct forum now. You posted it in the ISPConfig priority support forum but the topic is nowhere related to ISPConfig.
  6. IzFazt

    IzFazt Member HowtoForge Supporter

    I found the problem in the tutorial.

    Till, really, it's impossible this tutorial works on a minimal install using standard system utilities + ssh. I did not use a container (I am familiar with what you noted) , I used a VM in Proxmox. Do you guys use some default template for testing which has these dependencies in it already?

    changed to and THEN it works

    By the way, I respect your work. I am 62, working on Unix, Linux since 1985. When I say I met 5 which crashed I am serious. From now on I will report what I find.
    Last edited: Sep 3, 2021
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    We use a Standard Debian system, using the defaults that the Debian installer recommends at installation time. You can find such a setup e.g. here:

    And please see here:

    The most 'minimalistic' but complete way to install Modoboa is:

    > git clone
    > cd modoboa-installer
    > sudo ./ <your domain>
    So it's not only us that did not need additional packages, it works for the Modoboa developers as well.
    ahrasis likes this.
  8. IzFazt

    IzFazt Member HowtoForge Supporter

    Yes I noticed, even before I posted this topic, the similarity between yours and their setup on one page of them, but then again they also spread this pdf at the Modoboa site which solved my problem - and has the dependencies in it which I refer to noted on page 6 - anyway my problem is solved. Tnxs for your involvement and regards from Holland,

Share This Page