Postfix not working

Discussion in 'Installation/Configuration' started by bullshit, Mar 10, 2006.

  1. bullshit

    bullshit New Member

    I follow the Perfect Debian setup, and everything went fine till the moment when I tested Postfix. In the logs it shows like mail is delevered but nothing show up in the users' mailbox. Also sending mail is not working though according to the mail.log the mail has been sent succefully.
    I have chekced all the places for error, but can't find a solution. Any help apreciated.

    Thanks in advance
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post an excerpt of your maillog. Have you installed courier ans ISPConfig? then you will have to check the maildir checkbox in ISPConfig under management > server > settings on the mail tab.
  3. bullshit

    bullshit New Member

    Still not working

    I haven't install ISP just potfix + the usual LAMP in a Debian box.
    This is the mail.log output

    Mar 10 20:47:28 dedic202-169 postfix/smtpd[1344]: connect from[81.100.2020.105]
    Mar 10 20:47:28 dedic202-169 postfix/smtpd[1344]: 6169E76658:[81.100.2020.105]
    Mar 10 20:47:28 dedic202-169 postfix/cleanup[1347]: 6169E76658: message-id=<[email protected]>
    Mar 10 20:47:28 dedic202-169 postfix/qmgr[1254]: 6169E76658: from=<[email protected]>, size=897, nrcpt=1 (queue active)
    Mar 10 20:47:28 dedic202-169 postfix/smtpd[1344]: disconnect from[81.100.2020.105]
    Mar 10 20:47:28 hostname postfix/local[1348]: 6169E76658: to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: procmail -a "$EXTENSION")
    Mar 10 20:47:28 hostname postfix/qmgr[1254]: 6169E76658: removed

    ANd this is the, very simple one:

    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    myhostname =
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination =,,, localhost
    relayhost =
    mynetworks =
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    debug_peer_list =
    debug_peer_level = 4
    queue_directory = /var/spool/postfix

    I've googled and post the problem in 2 forums and still no solution. Any help apreciated before i become crazy with this headache

  4. falko

    falko Super Moderator Howtoforge Staff

    Please post the output of
    netstat -tap
    I guess you use Courier as POP3 daemon, but Postfix delivers to mbox...
  5. bullshit

    bullshit New Member

    Thanks for replying
    This the outpout of the command

    tcp 0 0 *:imaps *:* LISTEN 4220/couriertcpd
    tcp 0 0 *:pop3s *:* LISTEN 4133/couriertcpd
    tcp 0 0 localhost:mysql *:* LISTEN 17687/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 4083/couriertcpd
    tcp 0 0 *:imap2 *:* LISTEN 4170/couriertcpd
    tcp 0 0 *:www *:* LISTEN 23718/apache2
    tcp 0 0 *:10000 *:* LISTEN 23586/perl
    tcp 0 0 *:ssh *:* LISTEN 9595/sshd
    tcp 0 0 localhost:postgresql *:* LISTEN 25039/postmaster
    tcp 0 0 *:smtp *:* LISTEN 32557/master

    *The smiles are not part of the log!!!

    The problem occurred even before I installed courier and Idon't recall using o configuring courier as a smtp daemon

    If I send a email to a fake user, Postfix actually replies with the Undelivered mail but if I send a mail like sendmail -bv [email protected], I receive nothing and Postfix logs like the mail has been mail sent.

    Thanks in advance
  6. falko

    falko Super Moderator Howtoforge Staff

    Ok, you're using Courier as POP3 daemon (not SMTP daemon!) which means you must configure Postfix to deliver mails to Maildir. Run this:

    postconf -e 'home_mailbox = Maildir/'
    postconf -e 'mailbox_command ='
    /etc/init.d/postfix restart
  7. bullshit

    bullshit New Member

    It worked

    The problem seemed to be the mailbox_command pointing to procmail, after emptying it started to deliver. I had the home_mailbox=Maildir/ already.

    Thanks a lot for your time, Falko

Share This Page