Postfix says, "Message size exceeds fixed limit"

Discussion in 'Installation/Configuration' started by IntnsRed, Nov 19, 2005.

  1. IntnsRed

    IntnsRed Member

    System: Debian perfect setup with ISPConfig.

    In /etc/postfix/ I have:

    mailbox_size_limit = 0

    set. However, I still seem to have a message size limit imposed on SMTP. When I try to send myself a message with a ~40MB attachment[1] logging directly into my SMTP server, the log tells me:

    Nov 19 20:57:20 hostname postfix/smtpd[22875]: NOQUEUE: reject: MAIL from unknown[]: 552 Message size exceeds fixed limit; proto=ESMTP helo=<>

    Can anyone whack me with a clue-bat and explain what's happening? TIA.

    Footnotes: 1. Yeah, I know what FTP's for. This was a test. :)
  2. falko

    falko Super Moderator Howtoforge Staff

    What does
    postconf -n
    show for mailbox_size_limit?
  3. IntnsRed

    IntnsRed Member

    Last edited: Mar 4, 2011
  4. falko

    falko Super Moderator Howtoforge Staff

    I'm not quite sure, but maybe 0 means 0, not unlimited.:D Try to set another value like 104857600 (100 MB) and restart Postfix.
  5. IntnsRed

    IntnsRed Member

    The PostFix docs say that 0 in this case means unlimited.

    Either way, I've tried it with other values (and just now with the 100MB figure you suggested) and the response is the same.

    It seems strange. At first I thought it might be related to the virus scanner, spamassassin, and/or procmail imposing a limit. But that doesn't make sense, 'cause it seems the response is coming from SMTP/Postfix.

    Now, to add another curve into this ;), all attachments are not broken. I have had people send me smaller stuff (a single *.jpg attached to a mail, etc.).
    Last edited: Mar 4, 2011
  6. falko

    falko Super Moderator Howtoforge Staff

    Do you have message_size_limit set in your If not, what does
    postconf -d
    show for it?
  7. IntnsRed

    IntnsRed Member


    # postconf -d | grep message_size_limit
    message_size_limit = 10240000
    Well, there seems to be a limit after all (he says making a mental note that he seriously has to read up on the PostFix man pages and docs:).

    Yes, this value is set to 0 in (as per above). So now I wonder, how can this be changed to get rid of that ~10MB limit?
    Last edited: Mar 4, 2011
  8. falko

    falko Super Moderator Howtoforge Staff

    Simply set message_size_limit in, e.g.

    postconf -e 'message_size_limit = 104857600'
    and restart Postfix.
  9. IntnsRed

    IntnsRed Member

    Doh! (sound of hand hitting forehead)

    Whoops, sorry, I missed the transition from "mailbox" size limit to "message" size limit.

    Thanks much; problem resolved.
    Mary jane
    Last edited: Mar 4, 2011
  10. anand

    anand New Member


    I am setting up the following values in

    mailbox_size_limit = 0
    message_size_limit = 0
    virtual_mailbox_limit = 0

    However when i do a postconf -d and check the values it still shows me the following:

    mailbox_size_limit = 51200000
    message_size_limit = 10240000
    virtual_mailbox_limit = 51200000

    How can i remove this limitation. I tried to increase these values, also, however the values seem to remain fixed.

    Any help will be appreciated.
  11. falko

    falko Super Moderator Howtoforge Staff

    postconf -d
    shows the default values, whereas
    postconf -n
    shows your current values.
  12. Hellbound

    Hellbound New Member

    sorry, I don't even know what was my post,
    guess it was just a wrong copy/paste.
    Last edited: Sep 11, 2008
  13. bwragg

    bwragg New Member

    Is it possible to change the max size of a message per user or is it only a system wide setting?


  14. falko

    falko Super Moderator Howtoforge Staff

    It's a system-wide setting.
  15. ekkis

    ekkis New Member

    you need to restart the server
  16. hairydog2

    hairydog2 New Member

    Will ISPConfig overwrite my changes?
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    No. ISPConfig 2 does not configure that parameter.

Share This Page