[Postfix/smtp] 25 connection refused / connection timed out

Discussion in 'Server Operation' started by wewanwang, Dec 20, 2014.

  1. wewanwang

    wewanwang New Member

    Hello, I had setup a vps with the CentOS Apache installed.

    I am facing a problem with postfix, I can send & receive emails without problem but I got the bounced back emails in mail log.

    For your information, I have the port 25,110,587,993,995 opened on firewall and I also could telnet the host like google, yahoo on port 25. PTR & rDNS also been set and I had checked my IP at mxtoolbar.com, it is not being blacklisted.

    Below are the info of postconf -n.
    What could be causing this problem??
  2. w_anup

    w_anup New Member

    Can you check your smtp log
    there is some configuration error
    i am trying to send you mail its getting "bad syntax error"

    have a look--

    Connected to mr14146.mail.163.com (
    Escape character is '^]'.
    220 163.com Anti-spam GT for Coremail System (163com[20141201])
    helo mr14146.mail.163.com
    250 OK
    mail from:[email protected]
    500 Error: bad syntax

    try sending mail from your smtp..
    telnet 25

    use standard command you will come to know by seeing maillog.
  3. wewanwang

    wewanwang New Member

    Hi, thanks for your feedback.

    I tried to telnet like what you did, I got the connection timed out as shown in the mail log.

    But, I able to telnet gmail & localhost without problem..

    Any idea why? Thanks.
  4. wewanwang

    wewanwang New Member

    Weird...I noticed that I able to telnet from my others VPS which one of VPS hosted at same supplier - linode and another VPS hosted at digitalocean.

    The only one thing different among all the VPS is that this newly setup VPS is on CentOS7 while the rest on CentOS6.

    Nothing is block from my ISP...

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Centos 7 block all ports except ssh by default. did you open port 25 in the centos firewall?
  6. wewanwang

    wewanwang New Member

    Hi, Till.

    I had followed the guideline -perfect server on CentOS7, apache. I able to telnet other host like gmail, yahoo without problem. I had disabled the firewall on ISPconfig but still showing the same result.

Share This Page