Postfix tutorial on Etch

Discussion in 'HOWTO-Related Questions' started by jason_m, Apr 26, 2007.

  1. jason_m

    jason_m New Member

    I recently upgraded to Debian Etch from 3.1. Up until the upgrade I had no problems with my mail server. I had set it up exactly as stated in the Ubuntu version of the Virtual Users And Domains With Postfix, Courier And MySQL (Ubuntu 6.10 Edgy Eft) tutorial.

    After the upgrade I am unable to login to the mail server either using POP3 or IMAP I get an error stating that the username doesnt exist or the password is incorrect.

    I have tried searching around the forums and noticed that I am running a newer version of postfix, so I upgraded the mysql-*.cf files to replicate those from the Fedora Core version of the tutorial, but I am still having problems.

    Has anyone else come across this problem and found a solution?

    Here is what I am seeing in mail.log when trying to login using imap:

    Apr 25 23:31:42 reliablenetworx imapd: Connection, ip=[::ffff:]
    Apr 25 23:31:42 reliablenetworx imapd: LOGIN FAILED, [email protected], ip=[::ffff:]
    Apr 25 23:31:47 reliablenetworx imapd: LOGOUT, ip=[::ffff:], rcvd=65, sent=332

    The error message is almost the same for pop3.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you get any errors in your mysql logfile? If you dont have a mysql logfile, please activate logging in the my.cnf file and restart mysql, then try to login to pop3 again and check the logfile for errors.
  3. jason_m

    jason_m New Member

    There are no errors in the MySQL log files. Logging is turned on.
  4. falko

    falko Super Moderator ISPConfig Developer

    This is a mail I got two days ago:

    As Ubuntu Feisty and Debian Etch are very similar, this should work for Debian Etch as well. :)
  5. jason_m

    jason_m New Member

    I think Ive made the similar changes, restarted everything, and still the same thing. No changes, any other ideas?
  6. falko

    falko Super Moderator ISPConfig Developer

    Similar or the same? ;)
  7. jason_m

    jason_m New Member

    Exactly the same, however, I have been watching the mysql.log and ive noticed when I try to log in, it doesn't log any type of mysql query. However, when I send myself an email, I can see all kinds of mysql information.

    I am trying to login through squirrelmail (imap) and pop3, both saying the username is invalid or the password is wrong.
  8. jason_m

    jason_m New Member

    I still havent come up with a solution, any more ideas?
  9. jason_m

    jason_m New Member

    Issue resolved, somehow courier-authlib-mysql was missing. Possibly from when I upgraded. I got this package installed, everything now works :)

    Thanks to everyone who offered advice.

Share This Page