Postgrey repeatedly rejecting emails from all senders

Discussion in 'Installation/Configuration' started by snowweb, Aug 16, 2020.

  1. snowweb

    snowweb Member

    I am currently configuring my new server which sends outbound mail correctly and receives inbound email when postgrey is turned off, but rejects it continually when enabled (even after hours of retrying).
    I don't see any place in the configuration to check/set the retry period. Where should I check this?
    I have just received one "mail delayed" soft bounce message on my external sending email account which says:

    (domain names and ipaddresses masked)

    In my mail.log I'm seeing:
    Thanks for your assistance.

    Server Details
    OS: Ubuntu 18.04
    ISPConfig Version: 3.1.15p3
    Build in accordance with The Perfect Server – Ubuntu 18.04 (Nginx, MySQL, PHP, Postfix, BIND, Dovecot, Pure-FTPD and ISPConfig 3.1)
  2. snowweb

    snowweb Member

    Test message was finally recieved but after several hours (maybe four). Where can I check and adjust the delay time so it's around 15 minutes?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The delay time of postgrey is 300 seconds unless you altered it manually in /etc/default/postgrey file. The more likely reason for your long delay is that the sending mailserver did not retry to send earlier.
  4. snowweb

    snowweb Member

    Confirmed that I haven't changed the delay time and I've checked the /etc/default/postgrey file and there is no time entry in it, so default of 300 seconds should be applied.

    I can see many retries in the mail.log well after 300 seconds has elapsed. However, I also just saw the following, which is repeated with alarming regularity. I think this might be related but not sure how to proceed?
  5. snowweb

    snowweb Member

    Also, I just saw this in the mail.log:
    I sent an email to myself and it is received a few moments later, so local delivery is ok.
  6. snowweb

    snowweb Member

    This is now fixed. Thanks for your help.
    The major clue was when I found this thread which has identical symptoms and so first of all I tried adding /etc/systemd/system/postgrey.service with the content he suggested.
    I restarted postfix and postgrey but I don't think it fixed it, so I tried his other suggested solution, as below:
    This seemed to do the trick. When I do:
    I get
    Where as before I nothing was returned.
    I do have one or two other issues to resolve before I can put this in production, so you'll probably hear from me again!
    Thanks again.

Share This Page