ppp rx errors

Discussion in 'Installation/Configuration' started by najohnston, Dec 12, 2005.

  1. najohnston

    najohnston New Member

    Installed Mandriva free 2006. Connected to ISP by dialup 56k external modem. Can occasionaly receive web pages etc (may take several minutes to get google up) average transfer rate is about 40bytes/sec.

    Looking at output of ifconfig i see almost as many rx packet errors as tx packets sent. Nothing in syslog etc that i can see as being wrong. No dropped packets either.

    An eth0 interface is auto created for a firewire pci card, appart from that only the loopback interface and ppp0 are there.

    Just read some details to check for default route of offline, but not at my machine so can't try it out.

    Hardware is ok (worked on mandrake 10.1 an hour before new install) works under win98 now. Even tried a complete re-install to see if it was a install problem.

    Any ideas as to where the chain is going wrong?

  2. falko

    falko Super Moderator Howtoforge Staff

    Have you tried to configure your modem using the Mandriva Control Center?

    Does a
    ping -c2 www.google.com
  3. najohnston

    najohnston New Member

    ppp problems

    tried various things since first post.

    can ping say www.google.com but ping reports packets lost sust like ifconfig. Name resoultion takes a long time but once pings are up its about 150msec.

    Actual packet loss is about 25% not the 100% i originaly thought

    i tried nobsdcomp, noipdefault, defaultroute, novj, novjccomp, nopcomp, nodeflate, nomppc options in /etc/ppp/options but no success

    i logged all ppp traiffic to file and used pppdump -p to look at it. It reported bad FCS on some packets, don't know why but this is the problem - which is why i turned of all compression etc (not that it was using it as the pppd log file was making sense even without the -d option)

    It looks like something to do with ppp not networking or the server end.

    resolv.conf and route -n all look correct.

    One entry in the /var/log/messages file is interesting :

    just after pppd Connect:mad: ppp0 <--> /dev/pts/3 i get :
    hal.dev: DEVNAME is not set

    thats the only error visible.
  4. najohnston

    najohnston New Member

    ppp proble

    forgot to add :

    Used kppp and mandriva network for defining the connection. no difference between them other than ones used chap and the other the other (forgotten its name pap?)
  5. falko

    falko Super Moderator Howtoforge Staff

    What happens if you try to ping an IP address, e.g.
    ping -c2
    Can you post your /etc/resolv.conf?
  6. najohnston

    najohnston New Member

    ppp resolve.conf

    Using the control centre setup and once logged on resolve.conf is :

    nameserver # pp temp entry
    nameserver 195.92,195.94 # pp temp entry

    route -n gives :
    Destination Gateway Genmask Flags Metric Ref Use Iface UH 50 0 0 ppp0 U 0 0 0 lo UG 50 0 0 ppp0

    ifconfig ppp0 when conntected and packet errors :
    ppp0 Link encap:point-to-Point Protocol
    inet addr: P-t-P: Mask
    Rx packets:23 errors:7 dropped:0 overruns:0 frame:0
    Tx packets:33 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:1840 (1.7kiB) Tx vytes:1691 (1.6KiB)

    excuse all spelling mistakes, not at machine so can't copy/paste

    Somebody mentioned MTU size as a possible but i can't check it without re-installing the old OS (Its 1500 now but what was it with a working system). 1500 does sound big enough to me.

    Output form pppdump had bad FCS on a packet of 55Bytes.

    I'll try the ping c2 when i am at machine again.

  7. falko

    falko Super Moderator Howtoforge Staff

    You could try 1492 instead of 1500.
  8. najohnston

    najohnston New Member

    ppp problem

    will try different MTU size

    Have noticed on a print out that a bad FCS on a recvd packet may of been caused by a short packet

    - previous recvd packet ended something like
    0a ff ff 50 f7 00 00 00 00 01 03 03 02

    bad FCS packet ended
    b7 bf ff ff 50 f7

    have to look up ppp/ip packets and find out what the significance of ff ff 50 f7 is and if in ppp there should of been more bytes. Maybe something is dropping bytes so the FCS is calculated on the wrong thing (maybe even rubbish in the buffer.

    pity i didn't print out more back packets to see if there is a pattern there.

    ho hum - the beauty of source code

  9. najohnston

    najohnston New Member

    Not going to solve this. Rolled back to mandrake 10.1 and it works again. Can't spot any differnce in whats happening between the mandriva and mandrake.

    Mandriva 2006 free uses ppp 2.4.3-9
    Mandriva uses ppp-2.4.3-4
    Mandrake 10.1 uses 2.4.2-7

    pppd is now at 2.4.4 so i guess some bugs have been resolved.

    Did try 2.4.2-7 on mandriva-2006 as well as ppp-2.4.3-4 but same problem so it may not be a pppd problem after all (as it works fine on mandrake 10.1).

    The FCS failed packets are short according to the IP length, missing at least 9 bytes at the end - which is going to cause the bad FCS.

    Maybe i'll continue looking for the solution. But for now i have to get a working connection back up.

    Thanks for the advice, maybe these posting will of be of use to someone else as well.

  10. bruno.vernay

    bruno.vernay New Member

    Same problem

    I have the same problem.
    I have an error message : "couldn't find interface ppp0"
    and "hal.dev: DEVNAME is not set" too

Share This Page