Problem with email forwards

Discussion in 'Installation/Configuration' started by mislav, Sep 17, 2014.

  1. mislav

    mislav Member

    Hi there.

    Basic info:
    - debian 7, 64bit
    - ISPConfig
    Email problems
    - Do you use dovecot or courier as imap and pop3 server? Dovecot

    Problem description:
    Email are working normally, but the problem is when it comes to email forwarding.

    - [email protected] is set in ISPConfig as mailbox and "Send copy to" is set to (I've tried to set it only as forward, but same result) - email is delivered localy to [email protected] and successfully sent to gmail according to mail logs, but I instantly receive message from Gmail with subject "Delivery Status Notification (Failure)" because of

    Shortly, as far as I understood, email is sent from server which is of course not in TXT record and thus email fails. This happens with every single client that sends email to our mailbox, so there is no way to "whilelist" all of them. Solution would probably be to send email as original sender/original mail server/IP and not to send from this server.

    Postfix configuration:
    # postconf -n
    If anything else is required, please let me know.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is that your SPF record in DNS is wrong. You have to add the IP address of your mailserver that is used to send the email in the SPF record.
  3. mislav

    mislav Member

    Are we talking about wrong SPF record on this domain1.tld where mailbox account is located OR domain where I'm sending emails from? I assume we're talking about mailbox account where forward is set, but just to make sure.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Weare talking about the spf record of the domain that is used in the "from" address of the email. The purpose of spf records is to ensure that other servers can test if a email is send from a valid server and if you have a spf record for a domain, then all servers that shall be allowed to send emails for this domain have to be listed there.
  5. mislav

    mislav Member

    As I mentioned, I can't do that.

    From address is my personal email and it is possible to set there in spf record to allow this mail server to send emails.

    But then, [email protected] send email to [email protected] and it will fail, because google will say, hey...this IP is not allowed to talk in domain name. I can't say clients to add our server IP addres in their spf record in order to communicate with us.

    I hope I understood you correctly.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The purpose of spf is to restrict the servers that are able to send email for a specific domain, so what happens here is that spf works and restricts the mail sending. What you can do is:

    1) If you want to use gmail for your mail service, then point the whole MX record for your domain to gmail.

    2) If you just want to be able to view the same mails at gmail too, then use the gmail pop3 connectot to fetch the mails from your server instead of forwarding them.
  7. mislav

    mislav Member

    Option 2) will probably be the solution in the end.

Share This Page