Problem with postfix install

Discussion in 'HOWTO-Related Questions' started by ctroyp, Nov 12, 2005.

  1. ctroyp

    ctroyp New Member HowtoForge Supporter

    Okay, I know it has been a while since this thread has been posted to, but I wanted to let you guys know that I have resolved the postfix issue on my Debian install. I finally figured a little more about DNS and what needed to be changed. was just a local domain that I was using for the server so I could setup the LAN. I didn't realize that it had to be a registered internet domain until falko and till pointed it out. Lessons learned for me...

    Since was up for sale for $900, I couldn't exactly justify the purchase so I simply registered another domain on the internet and used it to update the host files, etc... Now postfix works great and the emails are coming and going...

    This has left me with one issue--how do I update all of the files that still have listed? There is a large amount that contain it per rgrep strec command. So many that I don't even know where to start...

    I updated everything as I knew how to in the "Perfect Setup" for Debian 3.1 (ie. host files, and postfix). Are all of these 'other' files that contain strec generated by the ISPConfig install? If so, how can I efficiently and safely update them. I have not seen any problems yet, but I'm sure I will before too long.

    I can list some of the found files if necessary.
  2. falko

    falko Super Moderator Howtoforge Staff

    You could write a script (Perl, PHP, ...) or use sed and awk on the shell to do the replacement.
    What files are you talking about?
  3. ctroyp

    ctroyp New Member HowtoForge Supporter

    It may take some time to compile the list because most of them are grep'ed from mail files which are irrelevant. I will look into it deeper and give you a list.

  4. wr19026

    wr19026 New Member

    This has been helpful to some extent. I have now fixed the DNS issue (thanks for pointing that out!) and have done a 3rd install of Postfix using the ISP Config set up guide for Ubuntu 5.10.

    First of all apt does not get postfix-tls; is this a problem?

    Then, after doing all the setups I get the same trouble as the original poster; I cannot telnet to port 25 and if I do manage to get the connection ehlo does not do a thing.

    So I checked /var/logs/mail.log as suggested in an earlier post and here's what I found:
    server postfix/smtpd[6480]: fatal: no SASL authentication mechanisms
    server postfix/master[6463]: warning: process /usr/lib/postfix/smtpd pid 6480 exit status 1
    server postfix/smtpd[6463]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling

    So I added $myhostname to smtpd_sasl_local_domain in, reloaded postfix, restarted postfix and restarted saslauthd.

    server postfix/master[6463]: reload configuration /etc/postfix
    server postfix/master[6463]: terminating on signal 15
    server postfix/smtpd[6585]: daemon started -- version 2.2.4, configuration /etc/postfix

    Looks better right? Unfortunately I still get the Connection closed by foreign host when doing a telnet to post 25 on localhost.

    The only firewall (that I know of) is my router and just to be sure I have mapped port 25 to localhost on there.

    Any ideas?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, its a problem if you dont install postfix-tls.

    Please check your sources list again. It must be identical to the sources list used in the howto! Then run:

    apt-get update

    and run the steps for the postfix installation again incl. the postfix-tls setup.
  6. wr19026

    wr19026 New Member

    Ok thanks for the tip. Turns out I did have a typo in there :(

    However, even when I change it from nl.archive etc. to de.archive etc. it still won't install postfix-tls. The message I'm getting is (loosely translated) "Warning, postfix will be selected instead of postfix-tls" It also tells me that 0 packages are upgraded, 0 new packages are installed, 0 packages are removed and 2 have not been upgraded.

    These 2 packages are (found out using apt-get upgrade): linux-image-386 and linux-restricted-modules-386?

    Sorry for being a pain in the neck but do you have any suggestions what I need to do next?

    Thanks in advance!
  7. falko

    falko Super Moderator Howtoforge Staff

    I suggest that you check your settings against those of the Ubuntu setup. Maybe you made another typo somewhere.
    BTW, the best way to follow the tutorial is to use PuTTY on your Windows workstation and simply copy & paste the commands from the tutorial into the command window.
  8. wr19026

    wr19026 New Member

    Thanks, using PuTTY is a great tip. However, even after copy/pasting /etc/apt/sources.list it does not allow me to download postfix-tls, telling me that postfix is the most recent version. Also it tells me that it's excluding 2 files (see previous post) from updating.

    So I tried apt-get install postfix-tls; it didn't do a thing.

    I guess I have to start all over again by reinstalling Ubuntu and then use PuTTY to copy/paste my way through the tutorial as you suggest.
  9. ctroyp

    ctroyp New Member HowtoForge Supporter

    Again, most of these are log files, etc., but here are other files where "strec" was found that may be significant:

    Binary file /etc/sasldb2 matches
    Binary file /etc/aliases.db matches
    /etc/webalizer.conf:HideSite    *
    /root/ispconfig/httpd/conf/httpd.conf:ServerAdmin [email protected]
    /root/ispconfig/httpd/conf/httpd.conf:ServerAdmin [email protected]
    /root/ispconfig/php/include/php/main/php_config.h:#define PHP_UNAME "Linux 2.4.27-2-386 #1 Mon May 16 16:47:51 JST 2005 i686 GNU/Linux"
    /root/ispconfig/php/include/php/main/php_config.h:#define PHP_UNAME "Linux 2.4.27-2-386 #1 Mon May 16 16:47:51 JST 2005 i686 GNU/Linux"
    Would there be any problems manually updating these files to reflect my new domain name? The main ones I am concerned with are the dns records...
  10. wr19026

    wr19026 New Member

    So far, so good. I reinstalled Breezy and copy/pasted my way through the HOWTO without any problems. This is great! Now I have to figure out how to ftp to the server so that I can start with the ISPConfig install :)
  11. falko

    falko Super Moderator Howtoforge Staff

    It's sufficient if you update /etc/bind/, /etc/bind/, /etc/webalizer.conf, and /root/ispconfig/httpd/conf/httpd.conf.
  12. falko

    falko Super Moderator Howtoforge Staff

    Have a look at WinSCP:
    It lets you transfer files to your server without FTP.
  13. wr19026

    wr19026 New Member

    And again it all works like a charm :) I know this is off topic so I probably should create a new thread somewhere, but is there a list of recommended Windows tools somewhere? I now have PuTTY and WinSCP so I'm curious what more might come in handy in setting this all up.

    My longer term objective by the way is to migrate my home hardware as much as possible to Ubuntu so I plan on setting up a client/server environment on the Ubuntu server as well (currently prepared for ISPconfig and have just set up Samba). I will use your ISPconfig package to run one (maybe a few more in the future) domains.
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    I think these two are the most important ones, I use them daily :D

    If you want to test linux installations or some configurations, i recommed you to have a look at vmware workstation. They now have a free player software for the operatiing system images and there are some already installed linx systems for download. I use vmware for writing the linux howtos and ISPConfig development.
  15. ctroyp

    ctroyp New Member HowtoForge Supporter

    Thanks falko!

Share This Page