Problem with Quota

Discussion in 'HOWTO-Related Questions' started by spang, Jan 19, 2006.

  1. spang

    spang New Member

    Hey, when I was doing the "SAMBA (Domain Controller) Server For Small Workgroups With Ubuntu 5.10 'Breezy Badger'" tutorial and I was setting up quota, I ran into this message after doing "quotaon -avug":

    quotaon: using // on /dev/hda4 [/]: Function not implemented
    quotaon: using //quota.user on /dev/hda4 [/]: Function not implemented
    quotaon: using /home/ on /dev/hda5 [/home]: Function not implemented
    quotaon: using /home/quota.user on /dev/hda5 [/home]: Function not implemented

    I'm not really sure what kind of problem this is and how I should handle it. Thanks for any responses.
    Last edited: Jan 19, 2006
  2. themachine

    themachine New Member HowtoForge Supporter

    Do the quota files exist? Did the command "quotacheck" successfully run? If not, what is the output of "quotacheck -maug"? Note that I believe this command will overwrite your existing quota files...
  3. falko

    falko Super Moderator Howtoforge Staff

    Did you install the quota package?
    apt-get install quota
    What does /etc/fstab look like?
  4. spang

    spang New Member

    Yes, quota is installed, I'm not that stupid.

    I also ran quotacheck and the output seemed fine. It didn't show any errors. I did, however, run it over ssh, but that shouldn't change anything, should it?

    The computer where I was testing the tutorial on is off right now, but once I turn it on, I'll rerun all the tests and keep your suggestions in mind. I'll reply with any progress I make.
  5. falko

    falko Super Moderator Howtoforge Staff

    No, that's fine.

    Maybe you have to load the quota module when you boot your server. Is the quota module in /etc/modules?
    You might also have to install module-init-tools:
    apt-get install module-init-tools
  6. spang

    spang New Member

    Ok, so I've tried everything but to no avail. Still the same old "Function not implemented" warning. I've already loaded quota in /etc/modules and I ran "quotacheck -maug" a few times and nothing shows up. I also already have the latest version of module-init-tools.

    This is what my /etc/fstab looks like (I'm running my server off of an iBook so there's no boot partition):
    # /etc/fstab: static file system information.
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/hda4 / ext3 defaults,errors=remount-ro,usrquota,grpquota 0 1
    /dev/hda5 /home ext3 defaults,usrquota,grpquota 0 2
    /dev/hda3 none swap sw 0 0
    /dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
  7. falko

    falko Super Moderator Howtoforge Staff

    Please put
    into /etc/modules and reboot again.
  8. spang

    spang New Member


    No... don't get excited... it still didn't change anything. The same old "Function Not Implemented" error. Maybe I should just reinstall it?
  9. falko

    falko Super Moderator Howtoforge Staff

    Maybe you should also put
    into /etc/modules.
    You can run
    on the command line to see all the messages that the system issued during bootup. Are there any errors related to quota?
  10. spang

    spang New Member

    Still nothing. No errors during bootup, either. Just the "Function Not Implemented" message. I think I'll just reinstall everything and see how it goes. Might have some progress there.
  11. burtathis

    burtathis New Member

    same problem


    I have the same problem on a mac-mini
    did you solve it ?
  12. spang

    spang New Member

    Well, I didn't get it to work with my iBook, so I used a generic PC instead and quota works fine. Hmm. I guess quota just doesn't like Macs.

Share This Page