problems mysql

Discussion in 'General' started by rayit, Nov 9, 2005.

  1. rayit

    rayit Member

    I have problems with mysql

    Is it possible to copy all files in:
    /var/lib/mysql/web20_db1 to a new server /var/lib/mysql/web2_db1
    without problems

    The problem now is that no users can connect to the database etc..
    I did an upgrade of mysql and that did not work with 42go
    now I downgraded but all is mixed up..

  2. till

    till Super Moderator Staff Member ISPConfig Developer


    Have you changed the file permissions to the mysql user and group on the new server?
  3. rayit

    rayit Member

    yes copying works super..

    The old server will be einstalled.
    I think mysql users got deleted etc..


  4. New Member

    Different problem

    MySQL is not working properly in ISPConfig for me!

    I cannot enable any databases for a site or client! So, if I go to
    ISP Manager --> <a site> --> Basis

    I cannot even see the option MySQL option.

    When I create a new site, I can see that option, but when I create the site I get:

    You cannot assign MySQL databases to this website.

    Next >>

    Why is that? Am I missing something or why would it not work? Does installing PHPMyAdmin like described elsewhere in the forum solve the problem?

    Also, the SSH login does not work from within ISPConfig. Is that because I'm running my sshd on a different port? Can I still run sshd on a different port, because of security? Also, here I have the same. When I create a new site I can see the option but not when I edit a site.

    You cannot assign shell access to this website.

    Next >>
    Last edited: Mar 27, 2006
  5. falko

    falko Super Moderator ISPConfig Developer

    Are you creating this web site under a reseller? Then make sure the reseller has the correct settings regarding databases, etc.
  6. New Member

    Yeah apparently that was the problem. Thank you. So obvious but I just didn't think of it.

    Shell access still doesn't work for that user though, although I checked the SSL option in the site as well as the user. I had a look at /etc/passwd and at the end of the line it says for the user:
    webx_xxx:x:10002:10002:Full Name:/home/www/webx:/bin/false
    Doesn't that mean there is no shell for the user? Why does ISPConfig not change this? I thought it's based on the /etc/passwd file???
  7. New Member

    OK, I tried something else:

    1. Added user webx_test
    2. checked the Shell Access (as I did before for the other user but that one existed before I added shell access for him)

    Shell access for webx_test works!

    The Shell access check box is active in the user webx_xxx but it doesn't work and also /etc/passwd doesn't indicate it should. Is it maybe a subtle bug?
  8. New Member

    OK, this is weird. I unchecked the check box for that user, saved, and checked it again, saved, and it works.

    Still it might be a very subtle bug in the code, maybe you should check this. But then it isn't that big a problem.

    So, to repeat what I did:

    1. Create reseller without MySQL and Shell access
    2. Create Client under this reseller
    3. Create website under this client
    4. Create user under this site (without MySQL and without Shell)
    5. Modify reseller to have MySQL dbs and Shell access
    6. Modify site to have shell and mysql
    7. Modify user to have mysql and shell, but shell and actually mysql as well didn't work

    Yeah, now that I go through it, how do I access mysql with a user that has shell access (or otherwise)? It doesn't seem to work with
    webx_xxx@www#mysql -p
    (with entering the users password)

    Also, if I enter mysql with my root user I cannot see any entry in the mysql.user table for webx_xxx or anything. How does this part work, because I didn't see any option in ISPConfig about enabling mysql access for users or similar?
  9. falko

    falko Super Moderator ISPConfig Developer
  10. New Member

    Hm, OK. Thanks, but the user does not appear in mysql when I log in as root. Also, I cannot log in with the database user (webx_u1), using:
    #mysql -uwebx_u1 -p
    and entering the password. I saved and everything.

    Thanks for you instant replies anyway.
    Last edited: Mar 28, 2006
  11. falko

    falko Super Moderator ISPConfig Developer

    It must be
    mysql -u webx_u1 -p
    (with space between -u and the username).
  12. New Member

    No, unfortunately this didn't work. As, I said, the users I create in ISPConfig do not appear in my MySQL database under mysql.user.

    So, when I do
    #mysql -uroot -p
    mysql> select user.User from user;
    I only get
    | User                   |
    | ispconfiguser        |
    | root                   |
    | *other non ISPConfig users*      |
    3 rows in set (0.00 sec)
    I tried creating one with/without remote access I did enter a password and the user appeared in the ISPConfig panel).

    Both didn't work from the shell login. Is it maybe a bug like I mentioned before with the general MySQL/Shell setup? Have you tried that possibility?
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    If you create for example a new email account, that works?
  14. New Member

    Yes it does. I just created a new email user webx_test under that site and it worked. It appeared in /etc/postfix/virtusertable at the bottom.
  15. falko

    falko Super Moderator ISPConfig Developer

    Can you check again with phpMyAdmin if the databases and users are really missing?
  16. New Member

    I finally figured out what the problem was. It was not a bug. When I installed, I created a user for ispconfig, who did not have enough rights on mysql databases.

    This did it for me:
    #mysql -uroot -p
    mysql> GRANT ALL PRIVILEGES ON *.* TO 'ispconfig'@'localhost'
        ->     IDENTIFIED BY 'some_password' WITH GRANT OPTION;
    Now, users are created and can log in which are created with ispconfig (webx_u1 etc.).

    Hope that helps people having the same problem. ;)

Share This Page