pure-ftp max settings

Discussion in 'General' started by pyte, Jul 14, 2022.

  1. pyte

    pyte Well-Known Member HowtoForge Supporter

    i've created a FTP User in ISPConfig and the FTP generally works. This user gets used from an automated system and logs in multiple times from different systems at the same time.

    I've ran into this issue:
    50 users (the maximum) are already logged in, sorry
    So i tried raising the MaxClientsNumber and MaxClientsPerIP to 200 within the config file at /etc/pure-ftpd/pure-ftpd.conf, and checked the passiv port range -> 45000 - 50000. However after raising it the issue still occures.
    Is /etc/pure-ftpd/pure-ftpd.conf the correct config file to set these values or ist the a special setup because of ISPConfig? Or do i have to create files called "maxclientsnumber" ... within the /etc/pure-ftpd/conf/ folder to make this work?
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Did you restart pure-ftpd?
    There is also PerUserLimits, which may trigger the same error message.
  3. pyte

    pyte Well-Known Member HowtoForge Supporter

    I did so with
    /etc/init.d/pure-ftpd-mysql restart
  4. till

    till Super Moderator Staff Member ISPConfig Developer


    Which Linux Distribution and version do you use?
  5. pyte

    pyte Well-Known Member HowtoForge Supporter

    This is one of my old webservers, rebuilding the whole setup right now but i guess i need to do this on the new servers too.

    root@www1:/etc/pure-ftpd# uname -a
    Linux www1 4.15.0-162-generic #170-Ubuntu SMP Mon Oct 18 11:38:05 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
    root@www1:/etc/pure-ftpd# cat /etc/lsb-release
    DISTRIB_DESCRIPTION="Ubuntu 18.04.6 LTS"
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ubuntu 18.04 uses systemd, so you do not use a script in /etc/init.d/ to restart services on that ubuntu version anymore. Using a init script instead of systemctl or service command might result in config changes not being applied.

    Besides that, most settings in pure-ftpd on Debian and Ubuntu are set via files in the conf folder, see here as an example:


    the max client settings file is:

  7. pyte

    pyte Well-Known Member HowtoForge Supporter

    Thats what confused me the in the first place as i thought so too. I've just checked the history on www1 and realised missed the '-mysql'. So tried:
    systemctl restart pure-ftpd
    Which obviously does not work because the unit is called pure-ftpd-mysql...

    Well i'll try that too. Thank you so much... i guess it's time for the weekend already ... :D

Share This Page