PureFTP failing authentication, no entry in the ISPConfig DB?

Discussion in 'General' started by jamiroph, Oct 22, 2014.

  1. jamiroph

    jamiroph New Member

    Hi All,

    I've come across a weird issue with my installation of ISPConfig3 on my Ubuntu 14.04 server. I've created a FTP user via the ISPConfig panel however when I tried to login to the server via FTP the connection was refused due to authentication failure. I've checked the firewall configuration and that PAM authentication is enabled in the PureFTPd config files.

    I decided to check what PureFTPd was getting back from the ISPConfig database so looked into the mysql.conf file the service was using.

    If I run the SQL statement to pull the password from the server I get empty so for some reason the web interface isn't running the SQL command to populate my FTP user table for PureFTPd to authenticate against.

    Any ideas anyone? I will admit I've done this backwards, posting to the forums first then Googling/documentation but I'm just looking for the shortest route to fixing it.

    Many thanks in advance
  2. Xenocide

    Xenocide Member


    ps aufx | grep server
    To see if you have an instance of the ispconfig /usr/local/ispconfig/server/server.sh running at the moment. It might be that it's been hung up and not completed yet hence the changes not being replicated from the source to node databases.

    Commonly I find that if mail queues build up then the script can timeout and not complete.

    Otherwise check your monitoring -> job queue tab to see if there's any outstanding jobs.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this a single or multiserver system?
  4. jamiroph

    jamiroph New Member

    Thanks to you both for your input.

    At the time of me submitting the FTP user change there was no server.sh process I could catch. The Job Queue only shows the recent changes to a mailbox I submitted and nothing about FTP.

    This is a single server setup.

    I've checked the MySQL database now (given it a few hours) and still nothing. Does the server.sh script get executed via the PHP script at the time I submit changes on the page or is the script run via cron instead? I'm hoping I haven't inadvertently broken a cron.

    I think I will start digging through config to find error_logs etc...
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    It is impossible that a ftp user that shows up in the ispconfig interface is not present in the database on a single server system as all you can see in the iterface is the direct resilt of a sql query on that one database. So if the user is visiable in the interface, then the interface must be connected to a different database then the server part and pure-ftpd.

    The server.sh cronjob is not relevant for this as a ftp user is one of the very few things that do not require a server action.
  6. jamiroph

    jamiroph New Member

    I've tried deleting the user then recreating it and the monitoring job queue shows them in the list but it does nothing.

    The interface must be talking to the correct database as there is only one mysql instance on the local machine and all other changes I make (adding mailboxes/sites etc...)

    I've enabled error logging via the ispconfig.vhost file as it was commented out for some reason and will see if that provides any more info.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

  8. jamiroph

    jamiroph New Member

    Thanks Till,
    I've got to the bottom of it, I restarted the service pure-ftpd-mysql and tested again and it all works.

    Not sure what was wrong with it. Thanks for your help anyway

Share This Page