Questions about the ISPConfig migration tool

Discussion in 'Plugins/Modules/Addons' started by brucebrown, Jul 18, 2017.

  1. brucebrown

    brucebrown New Member

    Does the ISPConfig Migration Tool support also Plesk 12.0 a source server?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, please see here:

    https://www.ispconfig.org/add-ons/ispconfig-migration-tool/

    "The migration tool helps you to import data from other control panels (currently ISPConfig 2 and 3 – 3.1, Plesk 10 – 12.5 and Confixx 3) into a new ISPConfig 3 or ISPConfig 3.1 single- or multiserver installation."
     
  3. cocovina

    cocovina New Member

    Just to be sure ...
    Does the migration tool change or delete any data on the source server?
    If migration fails, I still have the full functional source server as was before migration? ok?
    If migration will finished OK, I should have two identical server (excl. IP and name). ok?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    no.

    yes.

    Depends on how you define identical. The migration tool imports the websites, mail accounts etc. into the new server. So clients, websites, databases, mail domains, mail accounts, dns records etc. will be transferred.
     
  5. cocovina

    cocovina New Member

    @till THX for quick reply. seems to work fine. just problem with create some clients.
    i removed their VAT and company ID and then migration finished OK.
    but the VAT and Comp. ID is correct and legal CZ numbers. may be there is somew bug in migration script?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no bug in the migration script here, the VAT ID field is for European VT ID's an get's validated against the european vat ID database, you can not enter local vat ID's there any current ISPConfig version and not the migration tool rejected the ID, the id's were rejected by ISPConfig.
     
  7. cocovina

    cocovina New Member

    The mysqldump command does not dumped any data. No errors occured.
    I run it manually and I have seen that dump file contains just head info.
    Please see this ...
    [email protected]:~# mysqldump -cCQ --triggers --routines --quote-names --hex-blob -h ip.ip.ip.ip -u 75c0676f9dfcfd36 -p'********' c25_katerinadb
    -- MySQL dump 10.16 Distrib 10.1.26-MariaDB, for debian-linux-gnu (x86_64)
    --
    -- Host: ip.ip.ip.ip Database: c25_katerinadb
    -- ------------------------------------------------------
    -- Server version 5.1.73-1+deb6u1-log

    /*!40101 SET @[email protected]@CHARACTER_SET_CLIENT */;
    /*!40101 SET @[email protected]@CHARACTER_SET_RESULTS */;
    /*!40101 SET @O[email protected]@COLLATION_CONNECTION */;
    /*!40101 SET NAMES utf8mb4 */;
    /*!40103 SET @[email protected]@TIME_ZONE */;
    /*!40103 SET TIME_ZONE='+00:00' */;
    /*!40014 SET @[email protected]@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
    /*!40014 SET @[email protected]@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
    /*!40101 SET @[email protected]@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
    /*!40111 SET @[email protected]@SQL_NOTES, SQL_NOTES=0 */;
    [email protected]:~#


    Does someone have any idea where can be a problem?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You run the command on the old server, right? Did you check with phpmyadmin there there is data in the database c25_katerinadb ?

    If you have any problems with the migration tool, then please contact the migration tool support here: https://www.ispconfig.org/get-support/?type=migration

     
  9. cocovina

    cocovina New Member

    I ran the command on new (target) server. I copied it from migration command bash script, so it was exactly same as migration script generated/used. Of course the database contains tables and data. The migration script does the same probem for all databases.
    I ran the command on old (source) server used mysql root access and it exported DB right.
    I am going contact the ISPConfig support team.
    THX for your time and cooperartion.
     
  10. cocovina

    cocovina New Member

    Solution is add " --default-character-set=utf8" into the mysqldump command.
     
    till likes this.

Share This Page