quota issue

Discussion in 'Installation/Configuration' started by adamjedgar, May 5, 2017.

  1. adamjedgar

    adamjedgar Member

    During the Perfect Server installation...

    root@goanna-isp:~# touch /aquota.user /aquota.grouptouch: cannot touch '/aquota.user': No such file or directorytouch: cannot touch '/aquota.group': No such file or directory
    root@goanna-isp:~# chmod 600 /aquota.*chmod: cannot access '/aquota.*': No such file or directory

    I tried the solution offered on this forum in another post but it didnt work. So i thought perhaps another solution offered in https://askubuntu.com/questions/109585/quota-format-not-supported-in-kernel/165298#165298

    There's a bug filled into launchpad which describes and solves this problem.

    In summary, the quota module (and others) was removed from the virtual kernel. If you are in a Virtual Machine or aws-EC2 this should be your problem.

    The solution

    On Oneiric and Precise install linux-image-extra-virtual package. On old versions the modules should be already patched into kernel (just update your system).

    After that run modprobe quota_v2 and modprobe quota_v1 in order to get ready to run quotas. Also remember to put the modules on /etc/modules.

    Run your quotaon command as usual.

    So i ran the following command...

    root@goanna-isp:~# apt-get install linux-image-extra-virtual

    Still problems...
    quotaon -avug
    quotaon: using //quota.group on /dev/sda1 [/]: No such process
    quotaon: Quota format not supported in kernel.
    quotaon: using //quota.user on /dev/sda1 [/]: No such process
    quotaon: Quota format not supported in kernel.root@goanna-isp:/home/myuser#

    Does anyone have a solution to the quota issue that works on Google Cloud Instances? (perhaps its similar solution to what is needed for Amazon AWS?)

Share This Page