Quota Limits and Traffic Limits Not Working

Discussion in 'Installation/Configuration' started by protocol, Nov 24, 2005.

  1. protocol

    protocol New Member

    Hello again.

    I run Suse 10.0, have followed the 'perfect setup' guide, everything seems to be working perfectly with the exception of quota limits and traffic limits.

    First, let me say that i know the quota mechanism works on my machine because i set up quota limits manually (for a user not associated with ISPConfig) - no problem there.

    Yet, the one and only user i have created using ISPConfig does not appear at all when i run 'repquota -a'. So, i have decided that the web associated with this user should have a limit of 2 MB webspace (i know it is not enough, it is for testing purposes only), yet i uploaded a 12 MB image via a normal ftp client without any complaints whatsoever.

    Similarly, i downloaded this 12 MB image from my web browser without problems, despite the fact that i specifically assigned a limit of 1 MB of traffic (again for testing purposes). Since i certainly exceeded thia amount of trafic by downloading the 12 MB file, i should have received a notification email, which never came.

    Please assist

    P.S. Thank you for all the support so far. You guys are doing an excellent work.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    What quota do you have for the admin user. the quota of the web is the group quota of the admin user?

    The traffic limits are calculated once each night. You will have to wait for the message until the cronjob has run.
  3. protocol

    protocol New Member

    Hi Till. I do not understand what you are saying. The user i have for this web is the 'administrator' user for this web. The quotas for the web itself have been set by the 'admin' user of ISPConfig. Am i doing anything wrong?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No. You have set the quota for the web. Thats OK so far. The quota for the web is a group quota. But what quota does the user "administrator" has? In the settings of the user, there where you can set the email address, password, etc..., there is the quota setting for the userquota of the administrator.
  5. protocol

    protocol New Member

    So, ISPConfig's 'admin' user, sets the quota limit for a 'web' to 2 MB, yet a 'user' of a 'web' can have unlimited quota? If so, what is the point for ISPConfig's 'admin' to set quotas at all (if mere users can override this setting)?

    I followed your advice, set the quotas for this particular 'web' to 2MB using the 'user's' parameters and it actually worked. The 'repquota -a' revealed that there was now a soft-quota and a hard-quota of 2 MB, and (yes) the 12 MB file could NOT be uploaded.

    Then i reverted this user's setting to 'unilimited' quota and i found out (again by running 'repquota -a', that the hard-quota limit has indeed been removed, but the soft-quota limit remained there - God knows why. This is a bug, yes?

    In my oppinion, when ISPConfig's 'admin' has set the quotas for a web to a certain limit (2 MB in my case), there should be *no* way to override this, especially if one is a mere 'user' of a web. Otherwise there is no point, is there?

    Please assist (and thank you). :)
  6. protocol

    protocol New Member

    Good morning everyone. It is the next day now, and the e-mail message that would be a warning for exceeding traffic limits (see previous posts) never came.:(

    Furthermore, i still wish i had some answers on the issues mentioned in my exact previous post. :(

    Best Regard to all.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Does ISPConfig shows Traffic for this website? Do you have cron errors in the syslog?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Only the admin user can override the Quota setting. If you are logged in as clent, you cant set a quota taht is higher than the quota of the web.

    ISPConfig deletes the quota with the quota utilities of your linux system.

    This is the caese. maybe your group quota is not working correctly.
  9. protocol

    protocol New Member

    :) :) Ok, now it is working properly (after recreating the user). :) :) Thank you once more.
  10. xavier

    xavier New Member

    2MB Limit uploading a file


    I can't upload weiles more than 2 MB using a web browser. But I set the max_file_upload to be bigger than that:

    ; File Uploads ;
    ; Whether to allow HTTP file uploads.
    file_uploads = On
    ; Temporary directory for HTTP uploaded files (will use system default if not
    ; specified).
    ;upload_tmp_dir =
    ; Maximum allowed size for uploaded files.
    ;upload_max_filesize = 10M
    upload_max_filesize = 55M
    Also changed the default -1 setting in the ISPCONFIG control panel.


  11. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not upload bigger files where / in which script and in which php.ini file did you change a value?
  12. xavier

    xavier New Member

    2 MB Limit

    I edited the file:


    I searched for the string "upload_max_filesize" and copied the appropriate line, changed the value from 10M to 55M (see previous post). Then restarted ISPCONFIG from the command line,

    /etc/init.d/ispconfig_server restart

    I read about thsi procedure here:


    Is that the correct procedure?

    When you say "You can not upload bigger files" you can't mean that there is an absolute limit to the filesize of uploads?

    Thanks Till
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    In which script do you want to upload these files?

Share This Page