quotacheck: Cannot find filesystem to check

Discussion in 'Installation/Configuration' started by xetic, Aug 11, 2008.

  1. xetic

    xetic New Member


    I am having a problem with the quote package and have been browsing google articles and only found articles telling me to insert the usrquota,grpquota which I have already inserted as seen below:

    www:/# cat etc/fstab
    # /etc/fstab: static file system information.
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/sda6 / ext3 defaults,errors=remount-ro,usrquota,grpquota 0 1
    /dev/sda1 /boot ext3 defaults 0 2
    /dev/sda5 none swap sw 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

    www:/# ls
    backup.tgz dev initrd lib mnt quota.group sbin sys var
    bin etc initrd.img lost+found opt quota.user selinux tmp vmlinuz
    boot home initrd.img.old media proc root srv usr vmlinuz.old
    www:/# chmod 600 /quota.*
    www:/# mount -o remount /
    www:/# quotacheck -avugm
    quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.

    Any help would be greatly appreciated.

    Deleted entire line:
    /dev/sda6 / ext3 defaults,errors=remount-ro,usrquota,grpquota 0 1

    and retyped it, saved, remounted, and all worked fine....
    Last edited: Aug 11, 2008
  2. Nino

    Nino New Member


    I'm having the same problem (and others) and retyping the file, remounting, as you did the problem is still there.

    Any help?


    PS OS: Fedora 8 on a VPS
  3. falko

    falko Super Moderator ISPConfig Developer

    What exactly did you do, and what error message did you get?
  4. Nino

    Nino New Member

    Hi Falko,

    I installed ISPConfig following this guide:

    So I installed quota.

    Then I changed my /etc/fstab into:
    /dev/sda1       /             ext3     defaults,usrquota,grpquota  1 1
    /dev/sda2       swap       swap    defaults                            0 0
    LABEL=/boot    /boot       ext3     defaults                            1 2
    tmpfs             /dev/shm  tmpfs   defaults                            0 0
    devpts           /dev/pts   devpts  gid=5,mode=620                 0 0
    sysfs             /sys         sysfs    defaults        0 0
    proc              /proc        proc    defaults        0 0
    Then I ran quota by:

    touch /aquota.user /aquota.group
    chmod 600 /aquota.*
    mount -o remount /
    quotacheck -avugm
    quotaon -avug
    But the quotacheck didn't work: "Cannot find filesystem to check or filesystem not mounted with quota option.".

    Thank you very much for your attention and for the program!
    Last edited: Dec 3, 2008
  5. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to reboot the system?
  6. vermax

    vermax New Member

    quotacheck prob

    I am having the same exact problem. I am running Ubuntu.

    Getting the same error:

    quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.

    I have indeed tried rebooting the system. Any other ideas?

    Thanks in advance
  7. Nino

    Nino New Member

    I rebooted the system but the problem is still there :(
  8. till

    till Super Moderator Staff Member ISPConfig Developer


    Make sure that you enabled quota in /etc/fstab for at least one file system as described in the perfect setup guide.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this a physical server or a vserver?
  10. Nino

    Nino New Member

    It's a VPS.
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, then your problem is that the vps either does not support quota or that quota is already applied by the master server and so can not be installed in the vm's again.
  12. Nino

    Nino New Member

    Quota wasn't already installed, because I asked the master server and he said I had to install it myself.

    What can I do if my vps doen't support quota?

  13. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not do anything as a vps is not a full server. ISPConfig will work without quota, but the limitation for webspaces and mailboxes will not work then.
  14. vermax

    vermax New Member

    physical for mine and i have indeed altered fstab accordingly with no luck
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    And you remounted the partition were you added the quota as described in the perfects etup guide?
  16. vermax

    vermax New Member

    mount -o remount /

  17. vermax

    vermax New Member

    Ok... well somehow overnight, I had a visit from the unix god and he blessed off on me having quotas because I wake up this morning and right after replying to the post I go in and just have a look and whalla, they are enabled and working. I have no idea what happened but hey, who am I to question the all mighty unix god.

    Anyways... onto my next question (thanks for the help above, greatly appreciated though)

    I once had an account with a hosting server that had disk quotas, ram quotas, and cpu usage quotas enabled. Every time you logged in, it performed an output to your motd that showed you how much you were using and how much you were authorized to use, and if you were over, it told you. Any ideas if there is a way to alter and use quota for this, or how, or if there is some decent documentation on it? (you could also type quota and see the same thing when logged into the shell)

    Thanks again in advance
  18. Nino

    Nino New Member

    Does that mean that I can't set resellers/clients or only that each reseller/client will have unlimited webspace and mailbox?

    Thank you very much for you kind help!

  19. vermax

    vermax New Member

    Well since the VPS is not allowing you to install/configure Quotas... You have no way of automatically regulating the disk space etc. of the users/clients you set up. You can manually watch the accounts, or create a cron job to every so often run a check on the disk space used by each directory and e-mail you, but anything past that, its going to be somewhat manual as far as enforcing it. However, I would check with your vps provider and double check on the quota thing as I have been with MANY vps providers that do indeed allow you to set up quota programs, however, it has to be done a specific way and the admin has to be involved in the setup.

    Hope this helps and does not hurt =P
  20. jkrell

    jkrell New Member

    I did two things when I encountered the problem others have experienced (error message when typing quotacheck -avugm) -- 1. I retyped my whole /etc/fstab by hand. 2. I added "c" to the command:

    quotacheck -acvugm
    and it worked. Just an FYI for others that may be experiencing this.

    BTW, quotacheck took a looooooong time to complete, but my drive is 1TB so that may have had something to do with it. :)
    borekon likes this.

Share This Page