Redirects started acting up

Discussion in 'General' started by Taleman, Jun 3, 2015.

  1. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    ISPConfig running on Debian 6 and 7.

    I have a website B that I redirected to another website A. Both sites were created ads sites in ISPConfig. The redirect suddenly stopped working. I tried to fix it but no luck. I do not understand why it does not work. I looked at the .vhost files, they seem OK to me.

    I tried removing the redirect to get something that works and then try again with redirects, but the index.html file in the web/ -directory is not shown, instead the generic page shows up. I could not see in the logs what is happening. It seems to me some other web page is shown, but I do not know which and how come this site works differently.

    I just now found another site on my other ISPConfig cluster that similarly redirects to a wrong place. I have not yet figured that one out, either.

    Is there something funny going on with redirects now?
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Continuing troubleshooting. Should I just remove the not correctly working sites and create them again? I can not find any reason why customer.tld goes to /var/www/index.html -file, and not to the directory specified in the .vhost file.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    This happens e.g. when the ip selected in teh website and the one in dns does not match or when there is a tpo in the domain name or a similar issue that causes the match between the incoming request and the vhost config file to fail.
  4. Richardmax

    Richardmax New Member

    can i use .htaccess for this issue?

Share This Page