Redirects the domain alias to another site

Discussion in 'Installation/Configuration' started by Hanz1711, May 7, 2021.

  1. Hanz1711

    Hanz1711 New Member

    Hi,
    I have created an alias smidl.web01.smidlonline.cz for the domain smidl.online. The domain smidl.online is not redirected to my nameservers yet. After loading https://smidl.web01.smidlonline.cz/wp-admin/ I will get the message ERR_CERT_COMMON_NAME_INVALID with another domain name ctyrnohysvet.cz. After clicking that I still want to go to the page, I am redirected to another website - ctyrnohysvet.cz. Where could the problem be?
    ctyrnohysvet.cz.

    ctyrnohysvet.cz. is a site created in ispconfig

    upload_2021-5-7_10-38-7.png
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Th0m likes this.
  3. ahrasis

    ahrasis Well-Known Member

    Is this WPMU? My preference would be to use alias domain with vhost so that each domain / subdomain can have their own LE certs.

    But I also read that you can also do the same without vhost i.e. with only one master LE certs which covers up to max 100 domains / subdomains.

    I never got the later to work with my nginx web server so I sticked to my preference.

    For your problem, I guess you just have to make sure the other domain / subdomain is included in the master domain LE certs so you won't have the said error(s).
     
    Last edited: May 8, 2021
  4. Hanz1711

    Hanz1711 New Member

    I'm sorry, but even after reading the instructions, I don't know what's wrong. I have three domains registered.
    First domain (DNS to my servers)
    upload_2021-5-7_15-1-36.png

    Second domain (DNS to my servers)
    upload_2021-5-7_15-1-54.png

    Third domain (DNS is not on my servers)
    upload_2021-5-7_15-2-8.png

    Alias (main domain: smidl.online)
    upload_2021-5-7_15-2-23.png

    I use Nginx
    Is there any setting that is wrong?
    My goal is to get an alias for a domain that is not yet redirected.

    Thank you for your help
     

    Attached Files:

  5. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Add the alias domain to the LE cert. You have disabled that currently. And disable the * subdomain, set it to www. (ISPConfig currently does not support LE wildcard certs)
     
    ahrasis likes this.
  6. Hanz1711

    Hanz1711 New Member

    It works. Thank you so much for your help.
     

Share This Page