Remote FTP

Discussion in 'Installation/Configuration' started by nsworld, Aug 5, 2005.

  1. falko

    falko Super Moderator Howtoforge Staff

    Can you open a new thread for that problem? Otherwise the current thread would handle two completely different problems. Thanks! :)
  2. tmerrill

    tmerrill New Member

    I still can't login

    I have followed the Fedora Core 4 setup. I am just trying to ftp using root / "my root password". I have created the /etc/pam.d/ftp file and I am still having no luck. What am I missing. Firewall and everything seems to be ok. My machine is listening for ftp. Please help I have looked everywhere for an answer.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Root login with FTP is forbidden in FC4 because the FTP protocol transfers password in clear text. Use an SCP client like WinSCP for windows instead.
  4. asiatype

    asiatype New Member

    hi all ... pls someone help me . I install proftpd in FC4 box. proftpd works i think because i can log in with the user i created 'useradd -g <group> -d </home/directory> <new user> '. The problem is i cant create a directoy and it says '550 <user>permission denied' thnx :d
  5. falko

    falko Super Moderator Howtoforge Staff

    In which directory is the user when he logs in using FTP?
    Please post your /etc/proftpd.conf here.
  6. pine

    pine New Member

    I've have the same problem with a mahine running under FC 4 installed in the standard fashion (not the Perfect Setup). I can, however, test the access to my ftp server successfully through the Netmonitor site ( I can't see any directory or file myself so I don't know how good the connection was.

    It appears that I can connect to my server only through the local IP, not external IP or the external host name. Can someone test my theory by connecting to my server ( with a login name of "tester, 1234abcd"? Please let me know what happend?
  7. falko

    falko Super Moderator Howtoforge Staff

    It's working for me, I could log in. Maybe it'S a firewall issue with your client PC.
  8. pine

    pine New Member

    You were able to log in and gain access to the files, were you not? I get the same problem with a client running under FC 4 and WindowsXP. The firewall built into the DSL router may cause my problem.

    Thank you.
  9. falko

    falko Super Moderator Howtoforge Staff

    Yes, I could log in and see all files.
  10. brainz

    brainz Member

    Hi all

    Im still having the same problem with proftp and its PAM authentication

    here is the log file
    Im wondering if you guys can help with this.....

    I have also included a FTP in the /etc/pam.d/ftp with the following in it...

    and it still has no effect at all i can login with a client i use smartftp but it doesnt let me login from the web ftp and the account has anonymous and ftp login rights activated.

    Any help wpuld be apreciated...

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    If you can login with smartftp, i guess the problem must be more related to the ISPConfig webftp then to your ftp server.

    Does the problem occurs only with one account or with all accounts?

    Can you please try to se a simple password (only a-z characters and numbers) for the FTP user (only for testing!). Maybe its a characterset conversion problem.
  12. brainz

    brainz Member


    I set the account to a much simplier password without special characters and that work..... I am now able to connect to the ftp server with the web and smartftp. Thankyou!!!!

    Yes it did occur with all accounts...

    However i have encoutered another issue and what i did is i deleted the log file and then logged into the ftp account then tried to upload a folder with files in it and it froze and disconnected.

    I checked the empty log and it was filled with this....

    The ftp server allows for most files to upload but some files it just freezes and disconnects. I tried to look this up on the net and i did find the meaning of setcred but it did mean a whole lot to me...

    Could there be some sort of issue the PAM modules i dont know but i couldnt seem to find any relevent info with regards to this issue...

    Im wondering to could it be related to Kerberos or pam_krb5 or something along those lines...

    Any help would be fantastic thankyou

  13. falko

    falko Super Moderator Howtoforge Staff

    What's in /etc/pam.d/ftp? Do you have a file /etc/pam.d/secretd or something like that? What's in it?
  14. brainz

    brainz Member

    Hi falko,

    In answer to this question

    i have this in it...

    In answer to these questions....

    I looked in the /etc/pam.d and there is no file in that directory with the filename secretd therefore there is no contence.

    your help would be apreciated...

    Last edited: Mar 6, 2006
  15. falko

    falko Super Moderator Howtoforge Staff

    What's in /etc/proftpd.conf?

    Can you do this?
    cp -p /etc/pam.d/ftp /etc/pam.d/secret
    cp -p /etc/pam.d/ftp /etc/pam.d/secretd
    Does it change anything?
  16. brainz

    brainz Member

    Hi falko,

    Thanks for your help...

    Ok i tried those two commands

    and from what i can tell all they really did is create two files secret and secretd and put the contense of ftp

    in them i run those commands and then tried but unfortunatly the ftp server when using smartftp client connects really fast but when i try to upload it still freezes on particular files and disconnects.

    Here is the proftpd.conf contense...

    From what i can tell the proftp.conf is pritty much standard and the only thing that i have added is this

    IdentLookups off

    in the global section.

    thankyou for helping me..

  17. brainz

    brainz Member

    Hi All,

    Just with regards to this issue i was wanting to post this like in the thought that it may come in handy to others that get this error below in there /var/log/messages which is related to proFTPd

    I found this link

    Which basically suggest that proFTPd is upgraded to [FONT=verdana, arial, helvetica]ProFTPD1.3.0rc5
    I dont know why or fully understand it but i has gotten ride of the the error message i was getting...

    I have looked at the release notes for this upgrade and the last part was interesting.....

    I dont know how this will have a impact on my server but what the hell its only a test server at the moment....

    Maybe you guys can tell me if this will cause issues later on.....
    I did the upgrade and everything seems to be still working fine except.....

    For some reason and i dont know why but when i found out im gonna strangle it..........

    When i upload say for example Joomla_1.0.8_eCommerceEdition_1.0.3.tar.gz
    certain files still make smartftp freeze and the server disconnects.

    So i would say that this error message i was getting now has no relation to the issue. Not only that i dont seem to be having any difficulty connecting using smartftp or the web version with in ispconfig...

    However i still have the issue where when uploading smartftp freezes and disconnects on certains files but this time theres no error message.... :confused::rolleyes:

    if anyone could help that would be excellent as well....

  18. falko

    falko Super Moderator Howtoforge Staff

    Does it happen in both active and passive mode?
    Is it maybe related to exceeding quota when you upload a file?
  19. brainz

    brainz Member

    Hi falko,

    Yes it does happen in both active and passive mode and depending on which mode im uploading that certain files cause the freeze and disconnect... and it is the same file everytime in the same mode.....

    I do remeber setting the 2 quota options usrquota and grpquota in the /etc/fstab file. What i understand from this is this is where users gets a quota file upload of a certain amount.... As far as i understand it :confused:

    As for knowing how to change it well ill leave it your capable hands to tell me how to change the quota limit....:D:cool:

    Ill tell you ones things forsure im learning a hell of alot and i would love have this issue solved... Without it i really cant have a live server i dont think....

    But thankyou helping with this one and all the other stuff i have asked....

  20. brainz

    brainz Member

    Hi falko,

    I dont know if this makes a difference


    I changed the WebSpace MB from -1 to 99999999 then tried the ftp but this has not seem to made a difference.

    brainz :cool:


Share This Page