Remote FTP

Discussion in 'Installation/Configuration' started by nsworld, Aug 5, 2005.

  1. falko

    falko Super Moderator Howtoforge Staff

    -1 means "Unlimited" in ISPConfig.
    What's the web space of the complete web site?

    Any errors in the FTP log?
  2. brainz

    brainz Member

    Hi falko,

    The webspace is set to -1 as well....

    Space MB: -1 [​IMG]
    Traffic MB: -1

    There doesnt seem to be any error in the message log....
    All i can really see is a whole lot of open and closed sessions


    seems like every 30 minutes exactly a session from is opened and closed striaght away....

    and someone that it think is trying to gain access....

    brainz :cool::rolleyes:
    Last edited: Mar 21, 2006
  3. brainz

    brainz Member

    Hi All,

    This is weird to me but i just tried to upload using the servers internal ip address to upload files and it works and it goes real fast....

    Im wondering why it wont upload or or disconnect using
    and it flies like a bat out of hell when i use the internal ip address for the server. ??? :confused:

    If i this about it logically this would tell me that there nothing wrong with the setup of proftpd on the server if it upload really quickly using the internal ip address but i jst cant think of what wiould be the issue where it doesnt allow me to upload all files using the ????

    (flies like a bat out of hell = really fast) <---- for those that arnt culturally from australia :D

    brainz :cool::rolleyes:
    Last edited: Mar 22, 2006
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you try to connect from inside your local network (where your server is located too) with your domain that points to your external IP?

    This might be blocked by your router, if the router has a spoofing filter.

    Also FTP is known to have problems to connect trogh a router. Please try active and passive FTP mode.

    This looks like a connection from the ISPConfig script that checks if the FTP server is online.
  5. brainz

    brainz Member

    Hi till,

    i look at the router and ports 20, 21 are avalible from outside....

    But strangely i found a lot of this in the log of the router

    i wonder what this is :confused:

    brainz :rolleyes::cool:
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    FTP uses more ports after the initial connection. Have you tried bot, active and passive FTP, as i suggested?

    Looks like your network address translation buffer was full. I suggest to ask your router manufacturer what might cause this.
  7. brainz

    brainz Member

    Hi after a little reading and diagnosis with a app called
    router connection manager 1.7.6 - This app watches the NAT table with all the incomming and out going and i sat there watching it while a upload to the web folder and at certain points i would say when the buffer memory is full it freezes the ftp upload which causes the ftp to disconnect.

    To be honest i really put it down to a bad choice of router for a server anyway maybe ill look at a something like a cisco 871W sometime soon.

    But thankyou for your help on this one....

    brainz :rolleyes::cool:
  8. ceesco53

    ceesco53 New Member

    worked for me too

    This worked for me after reinstalling Centos 5 (x86_64 btw) over top of itself after an easily recoverable (I lucked out) crash on the system drive. Thanks for the info, saved me a lot of headache!
  9. askmefor

    askmefor New Member

    ISP Config FTP Access

    Hi Guys, Thanks for your valuable comments and workaround. I've been following up many of threads for same problem withou any success.
    I've created ftp file under /etc/pam.d/ with the contents mentioned above, restarted proftpd and even rebooted the server but still invain.
    Oh btw I am running Fedora 8.0 and just installed this for the first time :) so totally a new to linux ...:p) thanks for your help in advance.
    my site works fine from Web-FTP, and all rest of the options works fine, even phpmyadmin works gr8, this is only hickup.. which I am still struggeling with....
    My FTP Client gives error
    Command: USER webx_xxxxx
    Response: 331 Password required for webx_xxxxx
    Command: PASS *******
    Response: 530 Login incorrect.
    Error: Could not connect to server
    Whereas same user/pwd works fine with WebFTP
    Last edited: Jan 2, 2008
  10. askmefor

    askmefor New Member

    Its resolved!!!! dont know what happened, But i've just recreated users, and sites, so far my testing looks alright, I'll do the thorough testing and will post any error.
  11. New Member



    I found simpler solution for this prob.


    ln -s /etc/pam.d/proftpd /etc/pam.d/ftp
    (CentOS 5.2 x86_64)

Share This Page