Replication failed.

Discussion in 'General' started by Maile Halatuituia, Nov 15, 2016.

  1. I have have a multi server setup running for amost 3 years now with no problem. Lately i notice one of my DNS server on the cluster cannot sync data with this error on the ispconfig.log

    ERROR - Replication failed. Error: (dns_rr) in MySQL server: (localhost) Data truncated for column 'type' at row 1 # SQL: REPLACE INTO dns_rr (`id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_id`,`zone`,`name`,`type`,`data`,`aux`,`ttl`,`active`,`stamp`,`serial`) VALUES ('7575','69','69','riud','riud','','39','219','$origin','','','0','172800','Y','2014-10-03 21:58:10','2016090101')
    15.11.2016-02:15 - DEBUG - Replicated from master: REPLACE INTO dns_rr (`id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_id`,`zone`,`name`,`type`,`data`,`aux`,`ttl`,`active`,`stamp`,`serial`) VALUES ('7575','69','69','riud','riud','','39','219','$origin','','','0','172800','Y','2014-10-03 21:58:10','2016090101')

    I assume the problem happen on the type column where a data from the control panel cannot update or else. ....

    Note :
    I have two other DNS server update from the same control panel with no problem but only this one with the issue. They all have the same column name etc etc but it cannot update ....
    Any hint would be very much appreciated.

    Thanks in advance.
  2. florian030

    florian030 Well-Known Member HowtoForge Supporter

    try this:

    ALTER TABLE `dns_rr` CHANGE `data` `data` TEXT NOT NULL;
  3. Thanks florian
    Are you refferring to the DNS server itself that have issue or the control panel ???
    thnaks once again
  4. i think it is with the column type not data .. please can you comment as i have run the command but still the same
  5. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

  6. After drop the table and recreate with the sturcture above it is still the same.
    How ever i try to insert instead it give this error again
    insert INTO dns_rr (`id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_id`,`zone`,`name`,`type`,`data`,`aux`,`ttl`,`active`,`stamp`,`serial`) VALUES ('7575','69','69','riud','riud','','39','219','$origin','','','0','172800','Y','2014-10-03 21:58:10','2016090101')
    -> ;
    ERROR 1265 (01000): Data truncated for column 'type' at row 1
    Is it possible that i can bypass this particular update or delete it on the Control Panel so it won't update this particular record and hopefully restored the rest of the data ....
  7. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    By chance did you recently update the master (eg. to 3.1) and forget to update this slave afterwards? (or vice-versa)

    There is a db table in the master that contains the jobs for slaves to perform, from memory (and having never messed with doing so myself) it might be sys_datalog; if you find the right entry there and remove it I imagine the slave will stop trying to perform the update - however, backup first and research/wait for a more experienced answer to doing so if you want to be safe. :)

Share This Page