Roundcube doesnt save language, identities and timezone settings.

Discussion in 'Tips/Tricks/Mods' started by maxx, Jun 12, 2006.

  1. Hans

    Hans Moderator ISPConfig Developer

    Personally, i do not think that this whole issue was a RoundCube bug.
    I use RoundCube for almost one year now on my servers and i can confirm that there where only problems when RoundCube was still in an early beta fase.

    I think that the problem was, that the RoundCube package provided by ISPConfig has been built on an older version then the latest release, which is 0.1-RC1.

    If you make the modifications within the file as describes here:, all should work fine.
    To login with the emailaddress as well you should only change the line:

    // Path to a virtuser table file to resolve user names and e-mail addresses
    $rcmail_config['virtuser_file'] = '';


    // Path to a virtuser table file to resolve user names and e-mail addresses
    $rcmail_config['virtuser_file'] = '/etc/postfix/virtusertable';

    On, i would like to see the software version, so it's clear where packages are built on.
    Last edited: Jun 26, 2007
  2. Hans

    Hans Moderator ISPConfig Developer

    In the mean time Till has published my new RoundCube 0.1-rc1.1 package at He also mentioned the version of the software, so it's clear on which version the package is based on.
    Thanks for that Till!

    With this version of RoundCube a lot of problems are solved.

    Have a look at this thread for update instructions:

    Have a look at this thread as well for adapting the login screen to your needs:
    Last edited: Jul 4, 2007
  3. planet_fox

    planet_fox Member HowtoForge Supporter

    I have see new version

  4. Hans

    Hans Moderator ISPConfig Developer

    I know that the 0.1-rc1 pure GPL version has been released.

    I wonder if it is necesarry to build a new RounCube package for ISPConfig for this version, because of it's different requirements and it's also based on 0.1-rc1. When an ISPConfig server has been setup according "The perfect setup" you should install additional software as well, otherwise the RoundCube package will not function.

    The RoundCube 0.1-rc1 pure GPL version requirements are:

    * The Apache Webserver
    * .htaccess support allowing overrides for DirectoryIndex
    * PHP Version 4.3.1 or greater including
    - PCRE (perl compatible regular expression)
    - Mcrypt (supporting Triple DES)
    - libiconv
    - Multibyte String (mbstring)
    - Database driver for either MySQL, Postgres or SQLite
    * php.ini options:
    - error_reporting E_ALL & ~E_NOTICE (or lower)
    - file_uploads on (for attachment upload features)
    - memory_limit (increase as suitable to support large attachments)
    * The PEAR framework with the following packages installed
    - DB (1.7.11)
    - Mail_Mime (1.3.1)
    - Net_SMTP (1.2.10)
    * A MySQL or PostgreSQL database engine or the SQLite extension for PHP
    * A database with permission to create tables

    Did you know that RoundCube is also available as Debian (unstable) package?
    Have a look here:
    Last edited: Jul 8, 2007
  5. planet_fox

    planet_fox Member HowtoForge Supporter

    I have yesterday install, it works.Have same Probleme with virtualuser file from postfix. I don't know what ahve till planning for the new structure of this file.
    Roundcube do when i set in config the mailuser to [email protected] set.
    I have yesterday idee I make a cronjob make a copy of this file all 60min and than remove all "www" .I don`t konw can I do.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If you do not want to have the records in this file, just set the website to external mailserver. But do not set the co-domain with empty hostname to external mailserver.

    The result is that you get email for but not for anymore and no lines for are listed in the virtusertable file.
  7. planet_fox

    planet_fox Member HowtoForge Supporter

    Ok I do morning testing. Thanks
  8. dmit

    dmit New Member

    saving prefs and [email protected] problem - solved

    There is a simple trick to get rid of both those annoying problems - roundcube not saving prefs and having [email protected] as default identity.

    The RoundCube package for ISPConfig has all the patches from applied, except this one:

    > When a user login with the email address for the first time, within
    > RoundCubes the identities section, the e-mail address will be displayed like:
    > [email protected]. As we want the email address to be displayed
    > like [email protected] do the following:

    > Change the line within /program/include/ file from:
    > $line = trim($line);
    > to:
    > $line = trim(str_replace("www.", "", $line));

    Once you patch this yourself you will not only have default user identity like [email protected], but also all user preferences will be saving without a problem as well.

    I think this patch should be included in the ISPConfig RoundCube package by default. ;)

    What should be implemented as well is to acquire the full user name from ISPConfig database. Right now, RoundCube when patched as explained in the howto, takes user info from postfix virtusertable file. But the username there is in the form of:

    [email protected] web1_user

    Although the ISPConfig database has the full user name as well. So as far as I see there are two options:

    1) patch the ISPConfig postfix configuration module so the full user name is added to virtusertable in the form of:

    [email protected] web1_user #Firstname Surname

    and patch RoundCube accordingly so it would use this commented info instead of web1_user.

    2) Patch RoundCube to acquire the info from ISPConfig database directly.
    Last edited: Jul 12, 2007
  9. Hans

    Hans Moderator ISPConfig Developer

    :confused: The current RoundcubeWebmail 0.1-rc1.1 package contains line $line = trim(str_replace("www.", "", $line)); already ! Check it by yourself within the file at line 670.
    Last edited: Jul 12, 2007
  10. dmit

    dmit New Member

    ??????????? :eek:

    Heh! I have downloaded the RoundCube.pkg file today from (just followed the link from HOWTO). I just didn't check, if it is the last version or not. But looks like the one from is different. :cool:

    I don't know which one is newer, but the hint above worked for me with no problem. Try to uninstall the package and reinstall again from then check again.
  11. Hans

    Hans Moderator ISPConfig Developer

    Last edited: Jul 12, 2007
  12. dmit

    dmit New Member

    But what was the reason for this? The previous one worked just fine except this small issue. But as I see this new package has it's own bugs which are not addressed yet. May be you should put both of the links there with small explanation?..
  13. Hans

    Hans Moderator ISPConfig Developer

    Within my howto at URL i mentioned the package at URL based on RoundCube 0.1 Beta 2.

    Recently, I updated the RoundCube package because of the new RC1 release and to solve some problems. I could not know that Till published my latest package to a different URL. (

    If it was published to the same URL, the link within my howto was still correct.

    As far as i know, the RC1 version works very nice on my servers and problems with this new package are not reported yet within the forums.
    Last edited: Jul 12, 2007

Share This Page