Roundcube not honoring upload_max_filesize when set via ISPConfig

Discussion in 'Installation/Configuration' started by wallycleaver, Sep 19, 2018.

  1. wallycleaver

    wallycleaver New Member

    Hey all,
    My question relates to roundcube, based on settings via ispconfig, so I am asking here. If this should go to roundcube support, or another group on this forum, please let me know. Thanks in advance.

    I had implemented the following for one of my sites.
    • upload_max_filesize = 551M
    • post_max_size = 550M
    This to worked properly for some time, then one day a user informed me that they were only able to do 2MB attachments. I checked and the settings were still listed under the sites options->Custom php.ini settings area.
    I tried removing and re-applying the settings to no avail, I also tried a resync and do not see anything helpful in the logs...although it is possible I am looking in the wrong log files.

    If I set the parameters in the global /etc/php.ini file roundcube sees the correct settings.
    Here is my setup
    • OS: CentOS Linux release 7.3
    • ISPconfig Version: 3.1.6
    • Roundcube version: 1.1.9
    • PHP: Fast-CGI
    • PHP Version: <blank>
    Has anyone run into this issue?
    Can you tell me which file ispconfig is updating to implement the settings?

    I appreciate any help you can provide.

    Thank you.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    RoundCube is normally a global alias, so settings of a website do not apply to RoundCube as RoundCube is not installed in that site. For RoundCube, the global settings in php.ini file apply.
  3. wallycleaver

    wallycleaver New Member

    Ok, Thanks for the reply.
    Just to confirm I am understanding.
    To modify the attachment max for the roundcube interface, the best method is to use the /etc/php.ini? If so, and again, just to confirm, it would then apply to all sites, correct?
    Just want to make sure as it would be nice if it there were a per site setting, and I really thought it worked for me in the past.

    The above isn't a ding, love the product!! ispconfig, and roundcube too :)
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Actually, there is just one RoundCube installation and this is not inside any of the sites, that's why the global setting applies here.
  5. wallycleaver

    wallycleaver New Member

    Ok, got it, and I knew it was a single instance, not sure why I thought it worked before.

    Thanks again for the info.

Share This Page